6
`VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
 process 20124: D-Bus library appears to be incorrectly set up; failed to read      machine uuid: Failed to open "/var/lib/dbus/machine-id": No such file or directory
 See the manual page for dbus-uuidgen to correct this issue.
 D-Bus not built with -rdynamic so unable to print a backtrace
 Aborted

If having trouble installing ffmpeg was not enough, the above output is what getting trying to install vlc.

All I did was download the linuxtech.repo to /etc/yum.repos.d/ followed by yum install vlc

Others have had same problem so tried downloading and installing dbus because there is nothing in dbus folder. So I yum removed and reinstalled, still nothing in folder.

Please does anyone know what is going on besides my being an obvious idiot? `

2
  • Is dbus-uuidgen command installed at all?
    – Braiam
    Commented Mar 2, 2014 at 6:54
  • dbus-uuidgen b75b8c495b4666a0fb21722600082a38
    – cea
    Commented Mar 2, 2014 at 8:08

2 Answers 2

5

I ran into the same issue and this command fixed it for me

sudo dbus-uuidgen | sudo tee /var/lib/dbus/machine-id 

Source: http://www.torkwrench.com/2011/12/16/d-bus-library-appears-to-be-incorrectly-set-up-failed-to-read-machine-uuid-failed-to-open-varlibdbusmachine-id/

4

You have to service messagebus start and then it goes away.

You have to do this as root because you can't, by default, use vlc as root.

I found this information here

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .