5

I am trying To Install the Oracle 11g r2 on Linux 6.1 but i am Not Successful since a couple of days.When I have done all prerequisites for oracle 11 g .But When I run The Installer I got this Error

Checking Temp space: must be greater than 80 MB.   Actual 18741 MB    Passed
Checking swap space: must be greater than 150 MB.   Actual 4095 MB    Passed
Checking monitor: must be configured to display at least 256 colors
    >>> Could not execute auto check for display colors using command /usr/bin/xdpyinfo. Check if the DISPLAY variable is set.    Failed <<<<

Some requirement checks failed. You must fulfill these requirements before

continuing with the installation,

Continue? (y/n) [n]

and after I press "y", I got this exception:

 Exception in thread "main" java.lang.NoClassDefFoundError
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:164)
        at java.awt.Toolkit$2.run(Toolkit.java:821)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:804)
        at com.jgoodies.looks.LookUtils.isLowResolution(Unknown Source)
        at com.jgoodies.looks.LookUtils.<clinit>(Unknown Source)
        at com.jgoodies.looks.plastic.PlasticLookAndFeel.<clinit>(PlasticLookAndFeel.java:122)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:242)
        at javax.swing.SwingUtilities.loadSystemClass(SwingUtilities.java:1783)
        at javax.swing.UIManager.setLookAndFeel(UIManager.java:480)
        at oracle.install.commons.util.Application.startup(Application.java:758)
        at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:164)
        at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:181)
        at oracle.install.commons.base.driver.common.Installer.startup(Installer.java:265)
        at oracle.install.ivw.db.driver.DBInstaller.startup(DBInstaller.java:114)
        at oracle.install.ivw.db.driver.DBInstaller.main(DBInstaller.java:132)

My environment variables in ~/.bash_profile are:

TMP=/tmp; export TMP
TMPDIR=$TMP; export TMPDIR

ORACLE_HOSTNAME=oracle; export ORACLE_HOSTNAME
ORACLE_UNQNAME=orcl; export ORACLE_UNQNAME

ORACLE_BASE=/u01/app/oracle export ORACLE_BASE
ORACLE_HOME=$ORACLE_BASE/product/11.2.0/db_1 export ORACLE_HOME
ORACLE_SID=orcl export ORACLE_SID
PATH=/usr/sbin:$PATH; export PATH
PATH=$ORACLE_HOME/bin:$PATH; export PATH
LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib; export LD_LIBRARY_PATH
CLASSPATH=$ORACLE_HOME/jlib:$ORACLE_HOME/rdbms/jlib; export CLASSPATH
DISPLAY=oracle:0.0; export DISPLAY

JAVA_HOME=/usr/local/java; export JAVA_HOME

Can anyone help?

3
  • 1
    There's no such thing as "Linux 6.1", is that RedHat? What's the java version you have installed (java -version)?
    – Mat
    Mar 1, 2014 at 10:42
  • yes i am installing on red hat and java is not installed Mar 1, 2014 at 11:12
  • 1
    The error comes from the fact that you're not running X. If this is a remote machine to which you have an SSH connection, run an X-client locally and connect using ssh -X to enable X11-forwarding. If this is a local machine, don't run installation on a text console.
    – user48669
    Mar 1, 2014 at 18:32

5 Answers 5

1

For RHEL, I did the following and solved this error.

If xclock is not installed, install it as shown below:

yum install xorg-x11-app*

then type xclock, and xclock will be displayed. Now, do this as root:

xhost +dwiba01-I114159.ca.com
su oracle
./runInstaller

Change dwiba01-I114159.ca.com to the domain you are connecting from.

1

If it still doesn't work, double check if you use su - oracle because Using su - oracle will break X screen forwarding or proper display when using Oracle runInstaller.

So you need ssh the host with user oracle.

0

The error message says the installer can't get at the X display. You probably need to start X as root (graphical login as root) to be able to do the install.

Yes, completely brain-dead. Who in her sane mind will run X as root? What correctly configured database server even has graphical tools installed, when it will be managed by CLI tools?

0

Seems like you need to just install Oracle Java to resolve this issue. The instructions for doing so are available on Oracle's website.

You can download the most recent version of Java from this URL:

You'll need to download the appropriate version for your architecture, 32-bit or 64-bit. I'd recommend downloading the RPM packages.

EDIT #1

Your issue is with the display variable, $DISPLAY. It may be set but it's unclear if you're doing this installation over SSH or on a locally accessed system. See this error:

>>> Could not execute auto check for display colors using command 
   /usr/bin/xdpyinfo. Check if the DISPLAY variable is set.    Failed <<<<

Try running that command, /usr/bin/xdpyinfo to confirm.

6
  • I have installed the java but error is same Mar 3, 2014 at 5:41
  • i am running xhost+ and error shows unable to open display ... Mar 3, 2014 at 5:42
  • The display is either not set or isn't accessible. Confirm that the env. var. DISPLAY is set, echo $DISPLAY.
    – slm
    Mar 3, 2014 at 13:22
  • DISPLAY=oracle:0.0; export DISPLAY sir this env variable is set as shown in post Mar 4, 2014 at 7:53
  • What is oracle in that statement? The local machine's name or some remote computer you're connecting from?
    – slm
    Mar 4, 2014 at 13:52
0

I was getting the same issue, I installed all GUI packages using yum then add:

$ xhost +<machinename>
$ su oracle
$ ./runInstaller

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .