1

I have installed the newest Erlang from source. As the final step I have executed

 sudo make install

Among other things, it placed erl link in /usr/local/bin, but its permissions are insufficient for me to use, other than with sudo

 lrwxr-x---  1 root  wheel    21B Apr 19 22:26 erl@

/usr/local/bin permissions:

 drwxr-xr-x  18 root  wheel   612B Apr 20 21:45 bin/

sudo gives enough permissions to execute, but not enough to change the permissions. The question is, how do I change the permissions on these symbolic links?

migrated from superuser.com Apr 21 '11 at 2:13

This question came from our site for computer enthusiasts and power users.

2

Are you using chmod's -h option (from the man page: "-h If the file is a symbolic link, change the mode of the link itself rather than the file that the link points to")? I tried it, and it seemed to do the job:

sudo chmod -h o+rx erl
0

Those are MacOS root files protected by Apple's System Integrity Protection
If path is set properly, it won't require root permissions to execute a symbolic link.

I wouldn't recommend, but you can allow user access by:
sudo chown -r $(whoami) /usr/local/bin

What is your current path? Heres mine for an example:
echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/MacGPG2/bin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.