1

First off, I've installed arch before, but managed to not encounter any of the problems I'm having at the moment (not sure how). But I'm well and truly stuck. First, my network interface is now called enp3s0 rather than eth0, so every time I start arch, I need to run

ip link set enp3s0

and then

dhcpcd enp3s0

how do I configure this so it happens automatically?

My second issue seems more peculiar; after booting into arch, I installed the enlightenment WM with pacman, and tried to run it, but apparently I did not have a couple of xorg packages, namely xorg-xinit, and another which I forget. After installing these however, editing the .xinitrc file, and running startx, I just got 3 white bash boxes on a black screen. Though if I run enlightenment_start in one of those boxes, enlightenment starts fine (albeit with 3 terminal boxes open, 2 I can close fine, but if the third is closed, enlightenment exits). I am certain this is not normal behaviour, and any help as to what I'm doing wrong here would be much appreciated.

0

Your first issue (the networking) can be automated with a systemd service file. You would use the dhcpcd@.service, in your case: systemctl {enable,start} dhcpcd@enp3s0.servive.

The other issue is that, when starting X, you are still starting twm. See Xorg page on the Arch Wiki on why this is happening, but essentially, X is being configured by /etc/X11/xinit/xinitrc. Create a correct ~/.xinitrc, log out and log back in as that user and it should start enlightenment.

  • Cheers, I understand better what's going on now, though there's still an issue that seems to cause startx to hang just after it gets to loading extension GLX. I can work around it by typing startx -- -extension GLX, but this is a pain every time I start my computer - do you have any ideas what this is to do with? – PointToPoint Feb 27 '14 at 22:47
  • Yep, apparently nvidia cards prefer nvidia drivers. Ignore that previous question, do you maybe know an easy way of replacing mesa-libgl with nvidia-libgl? it just complains that mesa and nvidia are in conflict, offers to uninstall mesa, and then refuses because mesa has stuff depending on it. Any clues? – PointToPoint Feb 27 '14 at 22:54
  • You can check through the dependencies with pacman -Qi mesa-libgl, and uninstall the necessary packages. – jasonwryan Feb 27 '14 at 23:10
  • Trouble is, all those packages have other dependencies too. Is there no other way to switch mesa for nvidia drivers? – PointToPoint Feb 27 '14 at 23:22
  • Just uninstall X and its dependencies and start from scratch; it will be simpler. – jasonwryan Feb 27 '14 at 23:52
0

My Arch linux box has a static IP address, but the Arch Linux Wiki says to do this:

# systemctl start dhcpcd@enp3s0.service
# systemctl enable dhcpcd@enp3s0.service

It looks like the weird device names are the Arch Standard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.