2

I have a postscript file (created using groff) which is a multi-page document. If I open it using ggv on Solaris 10 it opens correctly to page 1. When I open it using evince on Solaris 11 it opens to the last page of the document rather than the first. I tried the –page-label=1 command line open and that didn’t do anything (--page-label=2 does cause the document to open to page 2) Page 1 has a page header with the page number and everything looks like it does for page 2. I don’t see anything in the postscript file that would cause this to work for page 2 and not page 1 (although I haven’t worked a lot with postscript files, so maybe I am missing something) Using the –preview or the –presentation command line options also causes evince to open to the first page. Unfortunately, we would prefer not to use either of those settings.

Upgrading our version of evince is not an option as have to use the version that comes with Solaris 11 which, at the time we upgraded to Solaris 11 was version 2.30.3.

I am hoping that someone can help with either an answer or at least point me in the direction of finding an answer. I have searched the threads and cannot find anything related to my issue. I have also read through wiki.gnome.org/Apps/Evince and googled this problem. Clearly I am missing something.

If you have any suggestions on how I can fix this, or if this was a known issue that had a bug fix in a later release and you could let me know what release, I would greatly appreciate your input.

eta: A script is run to view the files. The script runs the following command:

groff -ms -Tps -t -f H -P-l ${Report} > ${TMPREPORT}; ggv ${TMPREPORT}; rm ${TMPREPORT}

So every time we view the report the postscript version is recreated on the fly and is then deleted when we are done.

1

Whenever I open a PDF file that I have read, evince (3.4 in my case) opens on the last page that I viewed from that that is what seems to be happening in your case as well. This information is not stored in the PDF (as with some viewers do with EPUB files), because if you rename the file, evince starts again the first page.

So you probably are using some cached value for 'last page read' whenever you access that page on Solaris. I have not found where evince puts that information¹, but renaming the file should do the trick.

¹ If you want/need to delete that kind of information, maybe this question helps, although the answers make clear that the location for evince' persistent storage has changed over time.

2
  • Thank you for this information. Knowing where this is kept will help with some of my testing since I had been skipping the file creation step; however in our official system the postscript file is newly created by groff when we attempt to display it (I have added the command to my original post) so that would not apply in this case. – user61526 Feb 27 '14 at 18:10
  • @user61526 If this is a new file with a new name then indeed evince should not be able to remember the "last page read" – Anthon Feb 27 '14 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.