0

I'm attempting to build the monotools-server app from source. After days of hunting down missing dependencies (and in one case (xsp) having to manually modify a generated Makefile to remove a reference to a test project which requires a missing Mono.Data.SqliteClient.dll, a bug which was reported over a year ago), I'm down to gtk+-2.24.

When I run the ./configure script for gtk+, I see yet more missing packages:

configure: error: Package requirements (glib-2.0 >= 2.27.3    atk >= 1.29.2    pango >= 1.20    cairo >= 1.6    gdk-pixbuf-2.0 >= 2.21.0) were not met:

No package 'atk' found
No package 'pango' found
No package 'cairo' found
No package 'gdk-pixbuf-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Okay, fine, so I download pango 1.28.4. The configure script

./configure --prefix=$HOME

runs just fine, and creates a whole mess of make files and .pc's.

When I run make, I get the error:

[slively@gpu1 pango-1.28.4]$ make
make  all-recursive
make[1]: Entering directory `/lustre/users/slively/download/pango-1.28.4'
Making all in pango
make[2]: Entering directory `/lustre/users/slively/download/pango-1.28.4/pango'
  GEN    s-enum-types-h
/bin/sh: line 1: ..//users/slively/lib/pkgconfig/./gobject/glib-mkenums: No such file or directory
make[2]: *** [s-enum-types-h] Error 127
make[2]: Leaving directory `/lustre/users/slively/download/pango-1.28.4/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/lustre/users/slively/download/pango-1.28.4'
make: *** [all] Error 2
[slively@gpu1 pango-1.28.4]$ 

A few things jump out at me:

First, the error:

bin/sh: line 1: ..//users/slively/lib/pkgconfig/./gobject/glib-mkenums: No such file or directory

What's up with that path?! ..//users/slively/lib/pkgconfig/./gobject/glib-mkenums? Aside from the weird ..// at the start of the path (it should be /users/slively/..., I searched my home directory for gobject and found:

[slively@gpu1 ~]$ find . -name gobject*
./bin/gobject-query
./include/glib-2.0/gobject
./include/glib-2.0/gobject/gobject.h
./include/glib-2.0/gobject/gobjectnotifyqueue.c
./share/man/man1/gobject-query.1
./share/glib-2.0/gdb/gobject.py
./share/gtk-doc/html/gobject
./share/gtk-doc/html/gobject/gobject-Boxed-Types.html
./share/gtk-doc/html/gobject/gobject-Closures.html
./share/gtk-doc/html/gobject/gobject.devhelp
./share/gtk-doc/html/gobject/gobject.devhelp2
./share/gtk-doc/html/gobject/gobject-Enumeration-and-Flag-Types.html
./share/gtk-doc/html/gobject/gobject-Generic-values.html
./share/gtk-doc/html/gobject/gobject-GParamSpec.html
./share/gtk-doc/html/gobject/gobject-memory.html
./share/gtk-doc/html/gobject/gobject-properties.html
./share/gtk-doc/html/gobject/gobject-query.html
./share/gtk-doc/html/gobject/gobject-Signals.html
./share/gtk-doc/html/gobject/gobject-Standard-Parameter-and-Value-Types.html
./share/gtk-doc/html/gobject/gobject-The-Base-Object-Type.html
./share/gtk-doc/html/gobject/gobject-Type-Information.html
./share/gtk-doc/html/gobject/gobject-Value-arrays.html
./share/gtk-doc/html/gobject/gobject-Varargs-Value-Collection.html
./lib/pkgconfig/gobject-2.0.pc
./lib/pkgconfig/gobject-2.0-uninstalled.pc
[slively@gpu1 ~]$ 

And, the only instances of glib-mkenums are in ~/bin and the donwload folder where I built glib.

[slively@gpu1 ~]$ find . -name glib-mkenums
./bin/glib-mkenums
./download/glib-2.28.6/gobject/glib-mkenums
[slively@gpu1 ~]$ 

What am I missing here? One thing I love about Windows: install = "click click, Accept."

HELP.

  • On what OS (if Linux, what distribution), and what architecture? Why aren't you installing binary packages (at least the gtk stuff should be a yum install/apt-get install/pkg_add/… away)? – Gilles Apr 20 '11 at 20:37
  • This is on Scientific Linux SL 5.5 (Boron), which seems to be derived from red hat. I don't have root access to the machine - just trying to get these items built in my home directory. – 3Dave Apr 20 '11 at 20:55
  • @David: I recommend getting the source RPMs and building them with a different installation directory (I think it's easy with rpm, but I don't remember how). – Gilles Apr 20 '11 at 20:57
  • Is the content of the RPM somehow different from the source tar ball? – 3Dave Apr 20 '11 at 21:04
  • @David: It might have patches that were needed on your distribution, and more likely and more importantly it will have a full compilation script. – Gilles Apr 20 '11 at 21:07
1

I had a similiar problem and after a long time of looking, I stumbled uppon the solutions which is very simple. I deleted all *uninstalled.pc files from my local pkgconfig directory. Hope it works for you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.