1

I have a very strange and intermittent problem. Sometimes, with no pattern I can discern, running exit fails to close my terminal emulator. In the screencast below, I open the first terminal and successfully exit with Ctrl + D, open a second one and it hangs:

enter image description here

Now the strangeness:

  1. This happens sometimes, not always, and I can see no pattern. In the gif above, it is the 2nd terminal, sometimes it is the first or the Nth.
  2. The same thing happens whether I run exit manually or hit Ctrl + D.
  3. I have a shortcut key mapped to terminator in my DE's (Cinnamon) keyboard settings. The problem only occurs when launching with this shortcut. It does not seem to ever happen if I launch by running terminator manually.
  4. It seems to be exclusive to terminator, neither xterm not gnome-terminal display this problem if I assign the same keyboard shortcut to them instead.
  5. It happens irrespective of what keyboard shortcut I use (I tried using Ctrl + O instead of the Alt + Z I normally use)
  6. It seems to be specific to Cinnamon, I tried on Mate and xfce and it worked fine.

Possibly relevant details:

  • This started happening after updating my LMDE to update pack 8.
  • The upgrade process was problematic because it wanted to install libharfbuzz0b which breaks libharfbuzz0a and some packages depend on the latter while others need the former. This has led to a bit of dependency hell which may or may not be relevant here.
  • terminator is a fork of gnome-terminal and Cinnamon is a fork of Gnome. The latest versions of Cinnamon have become completely independent of Gnome and in fact, you can no longer have both Gnome and Cinnamon installed on the same system. This makes me think that there may be some kind of library incompatibility between the Cinnamon-provided libs that terminator uses and the Gnome-provided ones it expects.

I realize that this is very likely to be an extremely localized problem that only affects my setup but I thought I'd put it out there in case anyone has any ideas on how to solve this or is experiencing similar issues. In the mean time, I have posted a bug report on terminator's bug tracker.

1

In the meantime, in case anyone else does have this error, here's my workaround. It seems to work fine if I don't define the shortcut in Cinnamon's settings but instead use an external tool like xbindkeys. So, follow the basic steps described in my answer here and then add these lines to your ~/.xbindkeysrc file:

"terminator"
Alt+Mod2 + z

Then, delete the keyboard shortcut from cinnamon's settings, add xbindkeys to your .profile so it is launched on login and everything should work as expected.

  • I am accepting this since the bug has since disappeared. Some update or other must have fixed it. – terdon Jan 19 '15 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.