I've installed Linux Mint 16 on a netbook that I'm trying to pump more life into. I'm currently stuck with configuring the wireless as the computer uses a USB wireless adapter (rt5370 from Ralink) due to its own wireless interface being hard blocked (the fn key is broken).

The connection is protected by WPA.

I installed the Linux driver, and I'm able to scan for networks nearby. However, when I try to:

$ wpa_supplicant -B -i ra0 -DWext -c /etc/wpa_supplicant.conf

I get:

ra0: Unsupported driver 'wext'

I've tried different drivers, and none of them work. I've also tried finding out what driver the wireless adapter uses (in theory it should be rt5370sta which is what I installed) to no avail. Tried lsusb, lspci -k, and lsmod; but none of them list the driver I need to be using.

Does anyone know whether I'm asking the right question or if the problem lies somewhere else? I was confident this was it as iwlist ra0 does work, and /etc/wpa_supplicant.conf is configured as per the instructions over here:

I tried wifi-radar, which gets stuck on the same issue (ends up completely unresponsive and I have to reboot computer in order to start it up again; killing the process doesn't work).

The computer has no internet access, but I can use Keryx to update or install packages.

Any help with figuring this out in order to get the internet working is very much appreciated!

  • What exact distribution are you using? Everything up to date? Kernel version? Where does the driver come from?
    – vonbrand
    Feb 25, 2014 at 19:26
  • Distribution: Linux Mint 16 Petra (Ubuntu 13.10, Saucy Salamander). Kernel: Driver came from the official Ralink site, I'd need to double-check from a proper computer (typing this from a tablet). As far as I know everything is up-to-date as I had run Keryx to install wifi-radar. It takes a snapshot of your dependencies and checks for updated ones when you plug it into a computer with internet.
    – Optimae
    Feb 25, 2014 at 19:57
  • I the driver distributed as source?
    – vonbrand
    Feb 25, 2014 at 20:36
  • According to wireless.kernel.org it is supported by the rt2x00 driver in the official kernel for some time now. Searching Google for rt5730 linux ralink gives tons of recent pages with instructions for Debian and Ubuntu.
    – vonbrand
    Feb 25, 2014 at 20:47
  • The driver came from: mediatek.com/en/downloads/… I did follow several threads extensively to get to this current stage. I'm going to double-check them in case there's something I might have missed.
    – Optimae
    Feb 26, 2014 at 0:53

2 Answers 2


What cards do I have?

You can find out what driver is being used per device like this using lshw:

$ sudo lshw -c Network -sanitize
       description: Ethernet interface
       product: 82577LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: em1
       version: 06
       serial: [REMOVED]
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.12-1 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:43 memory:f2600000-f261ffff memory:f2625000-f2625fff ioport:1820(size=32)
       description: Wireless interface
       product: Centrino Wireless-N 1000 [Condor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 00
       serial: [REMOVED]
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.12.9-201.fc19.x86_64 firmware= build 35138 ip=[REMOVED] latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:45 memory:f2400000-f2401fff

Which drivers?

Pay special attention to the configuration lines:

configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.12-1 latency=0 link=no multicast=yes port=twisted pair

configuration: broadcast=yes driver=iwlwifi driverversion=3.12.9-201.fc19.x86_64 firmware= build 35138 ip=[REMOVED] latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn

The parts that say driver= tell you which Linux kernel module is being used, which is the driver.

$ lsmod | grep -E "e1000|iwlw"
iwlwifi               112018  1 iwldvm
cfg80211              478020  3 iwlwifi,mac80211,iwldvm
e1000e                254311  0 
ptp                    18725  1 e1000e


You can find out more info about these drivers using the modinfo command:

$ modinfo iwlwifi | head -10
filename:       /lib/modules/3.12.9-201.fc19.x86_64/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
license:        GPL
author:         Copyright(c) 2003-2013 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:d
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
  • Relevant result from 'lshw': pastebin.com/SgyqdT9r The driver appears to be 'RALINK WLAN' The lsmod search doesn't show results for RALINK WLAN (or for different combinations, such as RALINK, ra). I looked at lsmod manually and couldn't see any RALINK entries either. 'modinfo rt5370sta | head -10' did yield results however. If rt5370sta is the driver, shouldn't it be listed when doing 'lshw'?
    – Optimae
    Feb 26, 2014 at 0:50
  • Here's what ralink is : en.wikipedia.org/wiki/Ralink, some are listed here too: wireless.kernel.org/en/users/Drivers
    – slm
    Feb 26, 2014 at 0:58
  • I can post full logs for each of those commands tomorrow, in case there's any more commands you think I should try and report results on. Thanks for the help! Edit: Just saw your previous comment -- will check it out thoroughly.
    – Optimae
    Feb 26, 2014 at 0:59
  • The rest of lshw would be helpful, The rt* drivers appear to be right for the RALINK. These appear to be all the related ones on my Fedora 19 system: rt2400pci rt2800pci rt2500pci rt2800lib rt2500usb rt73usb rt61pci rt2800usb
    – slm
    Feb 26, 2014 at 1:17
  • Here are the logs (including lshw): pastebin.com/y3zengxE
    – Optimae
    Feb 27, 2014 at 0:20

Don't use Ralinks drivers as they are unneccesary.
The RT5370 uses the uses the rt2800usb drivers on the kernel side, and the nl80211 drivers on the wireless side of things.

If you start afresh or if you remove Ralink's drivers, when you plug in the RT5370 you should get a wlan0 interface already.
If you use wpa_supplicant, specify the driver nl80211 when you're starting it, and it should work sweet. To specify the driver with wpa_supplicant, use the -Dnl80211 command line switch.

  • Could you expand a little? How does one specify a driver? Perhaps you could mention the relevant config file or modprobe etc.
    – terdon
    Feb 26, 2014 at 1:25
  • When I plug it in the wireless interface I get is called "ra0". It doesn't have to be "wlan0" right? I used -Dnl80211 without starting afresh and this is what happened: pastebin.com/XyRLk60t NOTE: the netbook's wireless interface is hard blocked but this is the first time I'm getting this message from trying to start wpa_supplicant.
    – Optimae
    Feb 27, 2014 at 0:12
  • You're getting ra0 because you're using the RALink driver. RALinks ra0 driver doesn't work with the linux mac80211 wireless stack (which is what the nl80211 driver uses), which is what the nl80211 driver uses. If you remove the RALink driver, you should get wlan1 which you should be able to use with the nl80211 driver with wpa_supplicant. AFAIK rfkill uses the mac80211 wireless stack, and won't be able to talk to ra0 as it's not using the same wireless stack.
    – Lawrence
    Feb 27, 2014 at 1:11
  • I unloaded rt5370sta and rt5572sta (which automatically appeared as a substitute to the rt5370sta). I also blacklisted both as they kept reloading themselves. No wlan1 shows up after replugging, rebooting...hm.
    – Optimae
    Feb 28, 2014 at 23:19
  • I used a live install and wlan1 does automatically appear as you said it would. When trying to start wpa_supplicant I'm now stuck with an rfkill: WLAN hard blocked. Rfkill list all reveals that phy0 continues to be hard blocked (which is the internal NIC that is irreversibly stuck in this state) but phy1 is not blocked at all according to the list. Is phy0 causing trouble by interfering somehow?
    – Optimae
    Feb 28, 2014 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.