0

iam using laptop dell inspiron 15R 5537 ... using dell wireless card 1705 ... and wireless is not defined on any linux distro i tried (ubuntu , debian , elemetary OS luna , gentoo ) :( i searched google for it .. but i couldn't find any useful solution ..

btw when it type ifconfig .. it displays lo and eth0 only .. and iwconfig no wireless driver ... and lspci it contain the network ethernet but no wireless defined

0

Then there is no driver for that card available. Perhaps a bleeding-edge distribution (rolling experimental release like Fedora's rawhide) has this enabled, or there is an experimental driver you can compile yourself. You might rummage in Linux wireless, perhaps there is something cooking there. I seem to remember Dell offered (offers?) some of it's machines with Linux preinstalled, perhaps you can find a driver there.

As a workaround, there are some USB WiFi cards that do work with Linux (but check them out first, I've got one at home that worked fine but only with open networks, any sort of encryption made it loose connection after a few minutes; should check how it goes now...).

  • Is this the same situation now? – Wilf Feb 14 '15 at 0:04
-1

The wireless card itself is designed by a top brand Qualcomm Atheros Communications Inc. The driver is inbuilt, and thus cannot be fetched online. Of course this driver doesn't support monitor mode and packet injection in Kali Linux until 2018.3a.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.