0

I also asked this question on AskUbuntu but there nobody comments on it

I have a konig rs232 serial to usb adapter (no FTDI chip), but when I try to connect to a cisco switch/router (via Putty, screen, minicom....), sometimes it just shows nothing (But it is connected because when i remove the USB it says disconnected, and sometimes it show garbage. But it also can just work ok, for about 5-10 seconds, after that it just freezes.

I checked the adapter on an other linux pc (slackware), and here it just works flawless. I'm running ubuntu 13.10 (3-11-0-15-generic , Lenovo laptop)

lsusb

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 025: ID 0cf3:3004 Atheros Communications, Inc. 
Bus 001 Device 032: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 003: ID 5986:0295 Acer, Inc 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg | grep 2303

[22933.099512] pl2303 1-1.2:1.0: device disconnected
[22934.926969] usb 1-1.2: New USB device found, idVendor=067b, idProduct=2303
[22934.927665] pl2303 1-1.2:1.0: pl2303 converter detected
[22934.929688] usb 1-1.2: pl2303 converter now attached to ttyUSB0

edit

I borrowed another converter from a friend (this one does have a FTDI chip), but it still doesn't work. I forgot to mention that i tried it on USB 2.0 as well as 3.0

BUMP

  • putty is a windows program. ! – X Tian Feb 25 '14 at 11:27
  • I know, but i tried to run it in wine because minicom & screen didn't worked also like i mentioned – radriaanse Feb 25 '14 at 11:45
  • Serial ports have to be configured in matching ways on both ends (speed, 7/8 bits, ...). Check how the CISCO port is set (by default, or perhaps reconfigured) and make sure your adapter is set correspondingly. [It's been a long time, sorry I don't remember details.] – vonbrand Feb 27 '14 at 15:07
  • All my settings are correct. I always use the same, standard Cisco settings; 9600 baud, 8 Data bits, 1 stop bit, no parity & none Flow control. – radriaanse Feb 28 '14 at 8:08
  • 1
    PuTTY can run natively on Linux perfectly well; I sometimes use it myself as a serial terminal. apt-cache search putty – Jander Feb 8 '15 at 3:03
2

If the parity and baud rate are incorrect, the console just will not work, and it's very unlikely to display anything at all.

If it's displaying something, the parity and baud rate should be fine.

Generally, Cisco consoles require the following settings:

9600 baud, 8 data bits, no parity, and 1 stop bit.

This is the document which taught me most of what I know about this, and it is a very kernel-centric issue:

Kernel.Org USB-Serial Documentation

Set Baud Rate, Data Bits, Parity, and Stop-Bit

stty -F /dev/ttyACM0 cs8 9600 -parenb -cstopb

STTY manual

Now, you what program are you using as your serial console?

Try to connect with whatever you are using.

I will look into if there are any specific issues with that kernel, since Ubuntu includes NON-FOSS packages.... I will let you know my findings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.