I have upgraded from Linux Fedora 12 to Fedora 20 by buying a new computer, and the shop has kindly installed Linux for me from the DVD I bought for the purpose. I assume he did the most basic installation he could. It is all strange coming from 12, and I am at a bit of a loss as to what to do next. The first thing I tried to do was use emacs, but it is not recognised as a command. I assume that it, and a lot of other software like gcc and gnuplot (also not recognised) are on the dvd, but access to, and installing, them is not obvious to me.

What should I expect to find on this DVD, and how can I install software from it?

The following is added as a response to the comment from @goldilocks.

I used yum all the time with Fedra 12, but when I tried it just now, in Fedora 20, this was the result:

[root@localhost ~]# yum install emacs
Loaded plugins: langpacks, refresh-packagekit
http://linuxdownload.adobe.com/linux/i386/repodata/repomd.xml: [Errno 14]     curl#6 - "Could not resolve host: linuxdownload.adobe.com"
Trying other mirror.
Error: failure: repodata/repomd.xml from adobe-linux-i386: [Errno 256] No  more mirrors to try.
http://linuxdownload.adobe.com/linux/i386/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: linuxdownload.adobe.com"
[root@localhost ~]# 

which all looks very strange. Probably I should use yum differently—my failing memory of version 12.

  • Do you have network connectivity? The error you're seeing is that yum can't resolve the repository's DNS. – jsbillings Feb 25 '14 at 2:41

Wow, so you never used yum with Fedora 12 ?!!? I'm guessing you installed everything by downloading and rpm? This is going to be like a trip to the future, lol. Rip Van Winkle and all that.

Anyway, the live DVD just contains enough stuff to do a basic install. For the past half dozen years or so, beyond that the norm is to use a networked package manager and online repositories. You can keep the DVD as a rescue disk, but it doesn't contain extra packages or serve any further purpose.

Try yum search emacs at the command-line (while you are online). This may take a minute or two while the remote repositories are checked, then you'll get a list of what's available. A sampling:

emacs.x86_64 : GNU Emacs text editor
emacs-a2ps.x86_64 : Emacs bindings for a2ps files
emacs-a2ps-el.x86_64 : Elisp source files for emacs-a2ps under GNU Emacs
emacs-agda.x86_64 : Emacs mode for the Agda language
emacs-agda-el.x86_64 : Elisp source files for Agda emacs mode
emacs-anthy.noarch : Compiled elisp files to run Anthy under GNU Emacs
emacs-anthy-el.noarch : Elisp source files for Anthy under GNU Emacs
emacs-apel-el.noarch : Elisp source files for APEL under GNU Emacs
emacs-asymptote.x86_64 : Compiled elisp files to run asymptote under GNU Emacs
emacs-asymptote-el.x86_64 : Elisp source files for asymptote under GNU Emacs
emacs-auto-complete-el.noarch : Elisp source files for Auto Complete Mode under GNU Emacs
emacs-bigloo.noarch : Compiled elisp files to run Bigloo under GNU Emacs
emacs-bigloo-el.noarch : Elisp source files for Bigloo under GNU Emacs

The base package is emacs, and yum install emacs will install it, but there's a long list of add-ons and the "x" version etc. you may want to look through. You do not have to use the part of the package name after the dot (e.g. .x86_64) since the right architecture will be used by default.

yum will calculate what dependencies are also required and present you with a list, then something like:

Total download size: 24 M
Installed size: 83 M
Is this ok [y/d/N]: 

Type y. For more information, see man yum and the copious online tutorials, references, etc.

  • 1
    Thanks @goldilocks. I used yum all the time in Fedora 12, never any trouble. My problem is that is gives a whole load of errors now I have Fedora 20 installed. I have the full DVD, not the Live one, but no idea how to read it to see what it contains. – Harry Weston Feb 26 '14 at 14:20

You can use the Fedora Installation Guide's instructions to set up a yum repository that refers to the DVD, if that's what you want to do, however, if you have network connectivity, you really ought to get your software updates off the Fedora mirrors.

  • Thanks @jsbillings. I would do that if it would definitely sort it all out, and if I could be sure it would cure all the associated problems. – Harry Weston Feb 26 '14 at 14:25

After a lot of frustration I decide to try a well-established version of Fedora instead of the newly released 20 installed by my computer supplier. I have now installed version 17, and, so far, all the problems seem to have been solve. I can now use yum with no trouble. I also was apparently missing a lot of the software, like gnuplot and ghostscript. I suspect that the installer of Fedora 20 had not included the software developer's repositories.

So, now my question is answered, redundant really, and I have, fingers crossed, upgraded from Fedora 12 to a decent working Fedora again.

yum list installed

will spit out a list of the packages installed (at least those in its database--read most), assuming you're booted into the DVD-image, or chroot'd in it.

Similarly,rpm always works:

rpm -qa  

Do yum repolist all to see a list of the repositories available to yum and their current state, i.e. enabled, disabled,etc.

[09:11][~]$ yum repolist all
Loaded plugins: auto-update-debuginfo, langpacks, list-data, refresh-packagekit
repo id                    repo name                     status
fedora/20/x86_64        Fedora 20 - x86_64            enabled: 38,597
!adobe-linux-x86_64     Adobe Systems Incorporated    enabled:      2

You should also take a look at Fedora's Release History and take notice of the release notes for major changes, like the recent change in package managers; starting in F20 users are encouraged to use dnf, which is an off-shoot of yum that was forked in 2012.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.