0

I wish to install tomcat7 on centos5 sticking on yum but I have

--> Finished Dependency Resolution
java-1.6.0-sun-compat-1.6.0.03-1jpp.i586 from jpackage-generic-nonfree has depsolving problems
--> Missing Dependency: jdk = 2000:1.6.0_03-fcs is needed by package java-1.6.0-sun-compat-1.6.0.03-1jpp.i586 (jpackage-generic-nonfree)
Error: Missing Dependency: jdk = 2000:1.6.0_03-fcs is needed by package java-1.6.0-sun-compat-1.6.0.03-1jpp.i586 (jpackage-generic-nonfree)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                    package-cleanup --dupes
                    rpm -Va --nofiles --nodigest

I've already tried with:

yum install java
yum install tomcat6
yum install tomcat7

these all end up with the same dependency resolution problem.

The enabled repos are:

[jpackage-generic]
name=JPackage (free), generic
mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0
failovermethod=priority
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc
enabled=1

[jpackage-rhel]
name=JPackage (free) for Red Hat Enterprise Linux $releasever
mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=redhat-el-$releasever&type=free&release=5.0
failovermethod=priority
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc
enabled=1

[jpackage-generic-nonfree]
name=JPackage (non-free), generic
mirrorlist=http://www.jpackage.org/jpackage_generic_nonfree_5.0.txt
failovermethod=priority
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc
enabled=1

# Updates

[jpackage-generic-updates]
name=JPackage (free), generic
mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0-updates
failovermethod=priority
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc
enabled=1

[jpackage-rhel-updates]
name=JPackage (free) for Red Hat Enterprise Linux $releasever
mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=redhat-el-$releasever&type=free&release=5.0-updates
failovermethod=priority
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc
enabled=1

[jpackage-generic-nonfree-updates]
name=JPackage (non-free), generic
mirrorlist=http://www.jpackage.org/jpackage_generic_nonfree_5.0-updates.txt
failovermethod=priority
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc
enabled=1

[jpackage-generic-6.0]
name=JPackage (free), generic
baseurl=http://mirrors.dotsrc.org/jpackage/6.0/generic/free/
gpgcheck=1
gpgkey=http://jpackage.org/jpackage.asc
enabled=1
  • Question unanswered in serverfault (serverfault.com/questions/577137/…) – lrkwz Feb 24 '14 at 16:23
  • Did you tried yum install jdk? – Braiam Feb 24 '14 at 16:34
  • Please don't cross-post, if you want this question here, delete your post on Server Fault. – terdon Feb 24 '14 at 16:36
  • @terdon As per the Q&A you reference, that's a debate, not an S.E. rule ;) Some of us are okay with cross-posting as long as it is explicit, which in this case it is, at least here. Meaning a parallel comment should be added to the serverfault question. – goldilocks Feb 24 '14 at 17:22
  • @goldilocks though I personally don't agree with it completely, closing with extreme prejudice seems to be the norm on all SE sites I frequent. Including this one, which even has a specific close reason just for cross-posting. I always thought that was kind of harsh, but having such a close message is certainly indicative of U&L' stance on this. – terdon Feb 24 '14 at 19:07
1

Using non-official repositories will cause grief (OK, you found that out already ;-). Check either Extra Packages for Enterprise Linux (EPEL) or Software Collections (SC) for what you are looking for.

You can do a yum --disablerepo=* --enablerepo=jpackage-* clean metadata (look it up in the manpage) and try again, if it was a hickup with the repository this might now work.

  • yum --disablerepo=* --enablerepo=jpackage-* clean metadata ; yum update java-1.6.0-openjdk did the job – lrkwz Feb 24 '14 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.