2

I have a remote compute server on which I would like to run VMD. Every time I start the application, it crashes with the following error report:

Info) VMD for LINUXAMD64, version 1.9.1 (February 1, 2012)
Info) http://www.ks.uiuc.edu/Research/vmd/                         
Info) Email questions and bug reports to vmd@ks.uiuc.edu           
Info) Please include this reference in published work using VMD:   
Info)    Humphrey, W., Dalke, A. and Schulten, K., `VMD - Visual   
Info)    Molecular Dynamics', J. Molec. Graphics 1996, 14.1, 33-38.
Info) -------------------------------------------------------------
Info) Multithreading available, 48 CPUs detected.
Info) Free system memory: 102376MB (79%)
Warning) Detected a mismatch between CUDA runtime and GPU driver
Warning) Check to make sure that GPU drivers are up to date.
Info) No CUDA accelerator devices available.
Warning) Detected X11 'Composite' extension: if incorrect display occurs
Warning) try disabling this optional X server feature.
XRequest.154: BadAlloc (insufficient resources for operation) 0x17
XRequest.154: GLXBadContext 0x3800001
Segmentation fault

I heard from other users of the same server that they did not have any problems, so I assume this must be an issue with the X window system on my local machine.

Further points:

  • I connect to the server using ssh -X.
  • Opening a remote xterm window works.
  • Local X windows version: 1.13.0
  • The log says "bad alloc" which suggests a lack of memory. How much RAM does your system have? – lgeorget Mar 3 '14 at 8:29
  • 7.7 GiB CPU RAM which are usually used at most up to 50%. Could GPU RAM be a problem? – gTcV Mar 3 '14 at 8:37
  • It's possible. Maybe you should pay attention to the warning about your GPU driver too. I'm not sure it's relevant to your problem though. – lgeorget Mar 3 '14 at 8:43
  • I think I have seen that warning message on the computer of a friend as well, but on his machine it worked. I therefore don't expect this to be the problem. Actually, I am more worried about the Composite extension warning, but haven't found a way to turn it off. – gTcV Mar 3 '14 at 8:48
2

The X server on your system cannot support GLX graphics. You can confirm this using the following command:

$ glxinfo | head -15
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_multisample, GLX_EXT_create_context_es2_profile, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
    GLX_OML_swap_method, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, GLX_SGI_swap_control
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
[saml@greeneggs Downloads]$ glxinfo | head -20
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_multisample, GLX_EXT_create_context_es2_profile, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
    GLX_OML_swap_method, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, GLX_SGI_swap_control
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float, 
    GLX_ARB_framebuffer_sRGB, GLX_ARB_get_proc_address, GLX_ARB_multisample, 
    GLX_EXT_create_context_es2_profile, GLX_EXT_fbconfig_packed_float, 
    GLX_EXT_framebuffer_sRGB, GLX_EXT_import_context, 
...

I'd confirm that you have the necessary OpenGL and MESA drivers installed, since this application looks to require access to those libraries, looking at the VMD website it would appear to have somewhat demanding needs from your hardware. When I say "your hardware" I'm talking about your local system, and not the one running the application, since your system is responsible for driving your local display.

CUDA?

In looking through the VMD website I did find this page, titled: VMD CUDA Acceleration Notes which sounds like it might be related to your particular warning messages as well, if you're curious to get rid of those. Also there is a message on that page that states: "VMD requires NVIDIA GPUs that support CUDA". A list of CUDA capable NVIDIA cards is also available.

BadAlloc

These messages would seem to be implying that your local video card does not have enough resource (GPU RAM) I would assume.

XRequest.154: BadAlloc (insufficient resources for operation) 0x17
XRequest.154: GLXBadContext 0x3800001
Segmentation fault

You might be able to get around this by reducing the size of your desktop display, potentially as well. You should be able to do this through your distro's control center, typically under the "Displays" applet. That's where it would be with a GNOME 3 type of desktop.

What Graphics do I have?

You can use the following commands to find this information out.

Method #1 - lspci

$ lspci -vvv -t | grep Graph
             +-02.0  Intel Corporation Core Processor Integrated Graphics Controller

Now we know the device ID (02.0) so we can use this to get additional information.

$ lspci -vvv -s 02.0
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Lenovo Device 215a
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 41
    Region 0: Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 1800 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915

ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
    Subsystem: Lenovo Device 2196
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0

Method #2 - hwinfo

$ hwinfo --gfxcard
08: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.319]
  Unique ID: _Znp.nUjOwTmEfZC
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Arrandale Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0046 "Arrandale Integrated Graphics Controller"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x215a 
  Revision: 0x02
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xf2000000-0xf23fffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  I/O Ports: 0x1800-0x1807 (rw)
  IRQ: 41 (23612176 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00000046sv000017AAsd0000215Abc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #8

Method #3 - lshw

$ sudo lshw -c display -sanitize
  *-display               
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:41 memory:f2000000-f23fffff memory:d0000000-dfffffff ioport:1800(size=8)
  • I resized my screen form 1600x900 to 800x600, but that did not fix it. Regarding your comment about the GLX graphics, I don't quite get what I should be looking for. When I run glxinfo, I get similar output to what you posted, but what does that tell me? Finally, my graphics card is Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) if that is any help. – gTcV Mar 6 '14 at 8:35
  • @gTcV - do any of your co-workers that have this working have anything besides NVIDIA? According to the VMD website docs it sounded like it would work w/ those cards only. The output for GLX tells you that it's working. – slm Mar 6 '14 at 13:03
  • I know of at least one friend for whom it works without NVIDIA. – gTcV Mar 7 '14 at 14:42
  • @gTcV - can you get more specific info about the video card? In my experience your issue is likely do to not having adequate hardware or not having native drivers (or they're not properly configured) which is causing your issue. – slm Mar 7 '14 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.