3

I configured my ftp user's home dir to /var/www and set a password but I cannot login with ftp 127.0.0.1, it keep giving me 530 Login incorrect. Why is this? I'm sure I have typed the password right.

edit 1 My config /etc/vsftpd.conf looks like:

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=YES
#
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
#listen_ipv6=YES
#
# Allow anonymous FTP? (Disabled by default)
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# If enabled, vsftpd will display directory listings with the time
# in  your  local  time  zone.  The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
use_localtime=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may restrict local users to their home directories.  See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
chroot_local_user=YES
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# Customization
#
# Some of vsftpd's settings don't fit the filesystem layout by
# default.
#
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd/empty
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
# This option specifies the location of the RSA key to use for SSL
# encrypted connections.
rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key

allow_writeable_chroot=YES

and permissions are set to 777:

reg@regDesktopHome:~$ ls -ld /var/www/
drwxrwxrwx 11 root root 4096 Feb 19 20:42 /var/www/

And the log file at /var/log/vsftp.log only says:

Tue Feb 25 21:19:38 2014 [pid 18250] CONNECT: Client "127.0.0.1"
Tue Feb 25 21:19:46 2014 [pid 18249] [ftp] FAIL LOGIN: Client "127.0.0.1"

Oh and syslog-ng doesn't say anything at /var/log/messages

  • What is the UID of your FTP user? I believe vsftp can only work with user ID numbers that are equal to or greater than 1000. – TSJNachos117 Apr 15 at 18:54
0

The permissions on this directory would be the first reason. Does ftp have write access to this directory?

$ ls -ld /var/www/
drwxr-xr-x. 4 root root 4096 Jan 27 08:38 /var/www/
$ ls -ld /var/www/*
drwxr-xr-x. 2 root root 4096 Jan 27 08:38 /var/www/cgi-bin
drwxr-xr-x. 2 root root 4096 Jan 27 08:38 /var/www/html

Can I ftp with /sbin/nologin?

You should be able to login using the ftp account even with the shell set to /sbin/nologin.

$ getent passwd ftp
ftp:x:14:50:FTP User:/tmp:/sbin/nologin

Logging in with the ftp account:

$ ftp localhost
...
...
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (localhost:root): ftp 
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> 

Log files?

Also I'm not sure how you've configured your vsftp server but you typically have log files so I'd check in there for any messages as to why you attempts are failing. They're often here: /var/log/vsftpd/*. I'd also check the /var/log/messages and /var/log/secure log files.

$ grep log /etc/vsftpd/vsftpd.conf
# You may override where the log file goes if you like. The default is shown
#xferlog_file=/var/log/vsftpd.log

My log shows my before/after I get write access to the /var/www directory for the user ftp.

Sat Feb 22 22:01:21 2014 [pid 27138] CONNECT: Client "127.0.0.1"
Sat Feb 22 22:01:33 2014 [pid 27137] [ftp] FAIL LOGIN: Client "127.0.0.1"
Sat Feb 22 22:01:36 2014 [pid 27155] CONNECT: Client "127.0.0.1"
Sat Feb 22 22:01:42 2014 [pid 27154] [ftp] OK LOGIN: Client "127.0.0.1"

You'll also see these failures in your /var/log/messages.

Feb 22 22:01:31 byers vsftpd(pam_unix)[27137]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=127.0.0.1  user=ftp
  • my /var/www is set to drwxrwxrwx and I don't want to login on the shell but by ftp, I don't need to set a shell then, do i? – cerr Feb 23 '14 at 2:15
  • @cerr - sorry I confirmed this and you're correct. You do not need a shell to login in this manner. I've updated my A. Sorry about the confusion. – slm Feb 23 '14 at 2:59
0

To enable all operating system users of the local computer to log in to ftp:

Edit /etc/vsftpd.conf, set the line

local_enable=YES

then restart ftp with service vsftpd restart

Put this here: http://www.linuxintro.org/wiki/Set_up_an_ftp_server

  • 1
    Thanks but local_enable ia already set to YES – cerr Feb 23 '14 at 19:16
  • please see edit 1 above. Thanks! – cerr Feb 26 '14 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.