1

edited 02-25: I thank @Anthon for his replies. I still do not, however, understand the meaning or the how of "pinging" ("Once you update your Q, ping the commenters..."). I also do not understand the meaning of "If you don't know what he means ask him in a comment under his" (?). I do hope he and the others excuse the fact that I've not contacted them directly about this updated question.

As well, thank you @Jenny D for your (patient and clear) instructions and information. I've printed them out and will use.

@ganessh: It is a NTFS drive

@Zelda - I pulled the drive because the computer in which it was installed had a failing (well, failed) motherboard, and I needed to get to the data. I had no problems with the drive when it was still in the (alive) computer.

@Babin Ionston-I downloaded the ntfs3g pkg (and vague instructions) but am having a difficult time with the installation. I will however, keep trying, and if unsuccessful, will write down the challenges and bring the question here.

It would be enormously beneficial for new members to receive a "write this/not that" message to make it very clear what information is needed by members to respond to a question (and I don't remember receiving such when I signed up, but perhaps I did). Although I'm quite honored with the patience shown by most of the folks who have responded to my question, I think doing so would save everyone time.

All: I will try out these suggestions (and instructions) and report back. Thank you.

=============

I have a lot of files on an external hard drive that I wish to access on my (now) Linux-based computer. The computer is now running Mint 16 (Cinnamon). The drive is a SATA drive I pulled from my Windows computer. That computer ran Windows 7. The problems I experience are:

  1. The drive appears on my desktop, and all of the folders on it (I believe) do display in the folder list. I can access some folders quickly (and see the contents) but not others (including the folder with the files I need--mostly Word/Excel files). These files are in a folder that was formerly in the Users folder on my Windows computer.
  2. My computer freezes when I click on this file (and this is the largest folder--approx 12 GB) I see a spinning disk and (I think) the word "processing"above it. Then the computer locks up: the cursor freezes, or doesn't freeze, but I can't close the window. I receive a message (I think it says "accessing") and a spinning disk, but the files do not open, and the computer freezes. I then have to reboot.
  3. I also tried copying the files to the computer, but was not able to do so (the freezing began).

My question: What do I need to access these files?

Also (and once again), what information should I provide you all to make answering my question(s) easier? Please note that I am new to Linux, so do not assume that I understand terms (like ping) or abbreviations that may be familiar to you.

closed as off-topic by psusi, jimmij, Networker, cuonglm, Michael Homer Jan 10 '15 at 5:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – psusi, jimmij, Networker, cuonglm, Michael Homer
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    In what way can't you access these files? Can you see the directory they're in but can't open it for example? – Joseph R. Feb 22 '14 at 8:01
  • If your unable to access files/folders to permissions, then open terminal navigate to that folder's parent and try this chmod 777 file/foldername – Bhupinder Feb 22 '14 at 8:30
  • What is the filesystem of the hard drive? – ganessh Feb 22 '14 at 10:27
  • Why did you pull the drive out of your windows computer. Did you have problems accessing the files or starting Win7? – Zelda Feb 24 '14 at 7:15
7

First, you need to find the actual path to the drive and the type of file system on it.

Open a terminal window and type mount. You will get a list that looks something like

[jenny@willow ~]$ mount
/dev/ad0s1a on / (ufs, local)
devfs on /dev (devfs, local)
/dev/ad0s1e on /tmp (ufs, local, soft-updates)
/dev/ad0s1f on /usr (ufs, local, soft-updates)
/dev/ad0s1d on /var (ufs, local, soft-updates)
devfs on /var/named/dev (devfs, local)

This is what the lines mean:

/dev/ad0s1f <--- is the device
on /usr     <--- path to the file system is /usr
(ufs,       <--- file system on the device
local, soft-updates) <--- other mount options

Your disk will probably have the file system ntfs instead of ufs or ext4 or whatever your other disks have.

Note the path to the file system - it is probably something like /media/nameofdisk or /mnt/nameofdisk.

Now that you have that path, you can change the ownership for all files on the media so that you can access them:

sudo find /media/nameofdisk -exec chown yourusername {} \;
find /media/nameofdisk -type d -exec chmod 755 {} \;

This will make sure that all files and directories on the disks are owned by you and that you can access all directories. If any files on the disks have restricted access permissions, add the following:

find /media/nameofdisk -type f -exec o+rw {} \;

to add read and write permissions on each file.

2

What you need is access permission. If the mount point of the drive is /media/old_drive, what you could do is:

sudo find /media/old_drive -type d -exec chmod 777 {} +

This will give everyone permissions to access (and write files into) all directories on that device.

  • This is what I typed in the terminal--and the response: sudo find /BabyDrive -type d -exec chmod 777 {} + find: `/BabyDrive': No such file or directory I also tried including the computer name in the path, but got the same result (no such file or directory. – user250988 Feb 23 '14 at 2:03
  • @Joseph R: the drive displays on my desktop, and all of the folders display when I click on the drive icon. I can access, that is, open some of the folders; the contents seem to be there. I cannot, however, open other folders. When I click on them (and this is the largest folder--approx 12 GB) I see a spinning disk and (I think) the word "processing"above it. Then the computer locks up: the cursor freezes, or doesn't freeze, but I can't close the screen. – user250988 Feb 23 '14 at 2:08
  • @ganessh it is a SATA drive that I pulled out of my old (and dead) laptop. I popped it into an enclosure, and plan to use it as a backup drive. – user250988 Feb 23 '14 at 2:09
  • @ganessh -realized I didn't answer your question. It was a drive running Windows 7 – user250988 Feb 23 '14 at 2:34
  • Unfortunately, I'm not clear on what isn't clear in/about my question. I've responded to each comment with additional information. Perhaps my challenge is that I'm so new to Linux that I don't have the proper/correct nomenclature to express my challenge. That is the reason I asked--in my original question--what information you would need from me to best provide me with an answer. I thought this was a place for noobs, so please tell me what isn't clear to you all and I will do my best to clarify. Thank you. – user250988 Feb 23 '14 at 7:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.