1

I'm trying to install Synergy in my CentOS 6.5, here's what happens:

# rpm -ivh ./synergy-1.4.16-r1969-Linux-x86_64.rpm
error: Failed dependencies:

libcurl.so.4(CURL_OPENSSL_3)(64bit) is needed by synergy-1.4.16-1.x86_64

And I have this libcurl package:

# rpm -qa |grep libcurl
libcurl-7.19.7-37.el6_4.x86_64

I've installed CentOS today, it's my first day using Linux.

  • Where did you get this synergy RPM? Often there are different distros which package up software that use various versions of "libcurl". You're likely butting into this. – slm Feb 20 '14 at 19:52
0

If you run rpm -q --provides libcurl you can see what your libcurl package provides. If you run rpm -qp --requires synergy-1.4.16-r1969-Linux-x86_64.rpm you can see what your synergy rpm requires.

The problem appears to be synergy was built against a libcurl package that provides libcurl.so.4(CURL_OPENSSL_3)(64bit) which the normal libcurl that comes with CentOS doesn't have. To resolve this you've got a few options

  1. Find the libcurl RPM that provides libcurl.so.4(CURL_OPENSSL_3)(64bit). I haven't been able to find it with some quick searches.

  2. Contact synergy and ask them about this.

  3. Assuming you have all the other dependencies, you could install the RPM with nodeps (rpm -ivh --nodeps synergy-1.4.16-r1969-Linux-x86_64.rpm) and it will probably work fine.

A few tips that won't solve your problem but will be useful to debug stuff

  • You can do yum searches for libraries by doing yum whatprovides 'libcurl.so.4()(64bit)'
  • You should use yum install or yum localinstall when installing standalone RPMs since it will resolve dependencies for you. It wouldn't have helped in this case but could in the future.
1

There is a Synergy bug filed about this issue. http://synergy-foss.org/spit/issues/details/3919/#

0

Oh no, some files of curl are in openssl or gnutls package, those doens't related to curl package. please innstall openssl or gnutls.

  • Both are installed already! Package openssl-1.0.1e-16.el6_5.4.x86_64 already installed and latest version Nothing to do ////// Package gnutls-2.8.5-10.el6_4.2.x86_64 already installed and latest version Nothing to do – Lucas Bustamante Feb 20 '14 at 19:05
  • after this message, i curl/types.h if i no made mistake, and comment some header files. but your case is binary files. – PersianGulf Feb 20 '14 at 19:13
  • oh by the way, please install openssl development package. – PersianGulf Feb 20 '14 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.