3

I usually work in a WM (i.e., i3wm) and use alsamixer to adjust sound volume.

The recent Linux installation on a Dell t5500 machine gives a very loud sound when set the maximum volume in alsamixer. It would damage my eardrum, if I mistakenly set the volume to be maximum as I usually use in-ear earphone. Is there anyway to set the peak sound volume?

1
1

not directly.

the only way i can think of, is by using a "virtual soundcard" that applies some pre-amplification (<1. so it's actually a pre-damping). thus when you set the volume to 100% (of your virtual soundcard) you actually have a softer volume setting in the real soundcard.

something like the following ~/.asoundrc (untested):

pcm.!default {
  type plug
  slave.pcm amp
}

pcm.amp {
  type plug
  slave.pcm "plughw"
  ttable {
    0.0 = 0.7 #amplication factor for channel 0/0
    1.1 = 0.7 #amplication factor for channel 1/1
  }
}

see asoundrc for more info on how to write a proper asoundrc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.