4

I tried to enable libass for ffmpeg with this --enable-libass in command but it didn't recognise the command.

Does anyone know how to enable libass on Linux?

  • what version of linux? It is possible libass is not installed on your system. – mkc Feb 20 '14 at 4:59
  • 2.6.32-358.2.1.el6.i686 – cea Feb 20 '14 at 5:08
  • What distro is what we should've asked. – slm Feb 20 '14 at 5:09
  • i386 GNU/Linux if that is what you mean. – cea Feb 20 '14 at 5:16
  • cea: please run the command "cat /etc/issue" on your terminal and show its output here. – Aquarius_Girl Feb 20 '14 at 6:30
3

First you need to make sure that your particular version of ffmpeg was built with and supports that switch. You'll also likely need to make sure that the library libass is installed as well.

You don't specify your Linux distro but I did notice that libass is available in my stock Fedora 19 repository so it's trivial to install.

$ sudo yum install libass

Now back to ffmpeg's support of libass. You can confirm how it was built by simply running it without any arguments.

$ ~/ffmpeg |& grep libass configuration: --prefix=/root/ffmpeg-static/64bit --extra-cflags='-I/root/ffmpeg-static/64bit/include -static' --extra-ldflags='-L/root/ffmpeg-static/64bit/lib -static' --extra-libs='-lxml2 -lexpat -lfreetype' --enable-static --disable-shared --disable-ffserver --disable-doc --enable-bzlib --enable-zlib --enable-postproc --enable-runtime-cpudetect --enable-libx264 --enable-gpl --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-gray --enable-libass --enable-libfreetype --enable-libopenjpeg --enable-libspeex --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-version3 --enable-libvpx

So the version that I have, does include this support, --enable-libass. If your version of ffmpeg doesn't support it you can simply download a static build:

  • It says nothing to do when tried simple yum install so that means it must be installed? I did download the static build. – cea Feb 20 '14 at 5:09
  • @cea - yes, you can confirm with this command too: rpm -aq libass. – slm Feb 20 '14 at 5:10
  • Thank you, it says libass-0.10.0-3.el6.i686 so I wonder why I am getting font config not found in output. That is the reason I'm trying to enable. – cea Feb 20 '14 at 5:14
  • @cea - see this FFmpeg ticket: trac.ffmpeg.org/ticket/1688 – slm Feb 20 '14 at 5:18
  • ok thank you, no-one was ever able to give him an answer "closed defect (invalid)" what ever that means, anyway I will have a think on it. – cea Feb 20 '14 at 6:24
5

On Ubuntu or Mint:

sudo apt-get install libass-dev
0

recompile ffmpeg with:

./configure --enable-libass

Then

make
sudo make install

Then check the new ffmpeg without arguments:

ffmpeg

Mine says "libass" is in the new config.

Then, to convert videos I use:

ffmpeg -i input.avi -vf "ass=subs.ass" out.avi

To obtain the subtitles in .ass from .srt I use:

ffmpeg -i subs.srt subs.ass

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.