1

I installed Debian 7 on an Asus Eee PC 2101HA.

Sometimes the screen goes black for 1 second.

My VGA card is VGA compatible controller: Intel Corporation System Controller Hub (SCH Poulsbo) Graphics Controller (rev 07)

6
  • 1
    If I have to guess it could be either someone making fun of you or the cable is damaged.
    – Braiam
    Feb 19, 2014 at 16:14
  • @Braiam I suspect OP means the built-in display. Which means its probably not a bad cable, unless OP has been disassembling the laptop.
    – derobert
    Feb 19, 2014 at 17:03
  • 2
    Note to anyone looking at this in the re-open queue: The Intel video driver, chipsets, or the displays attached to them are (or were) known to have bugs like this—much of this is fixed in newer kernels. This question isn't nearly as opaque as it at first appears (for details, see my answer, or ask Google about i915 screen flicker or similar).
    – derobert
    Feb 27, 2014 at 17:33
  • @derobert - you're assuming that one would characterize goes black for 1 second and flicker as being the same, which I wouldn't have thought of as being the same.
    – slm
    Mar 24, 2014 at 21:03
  • I agree, it's not what you'd normally think of as monitor flicker, which is something that only existed on CRTs. But really, its fairly similar—the screen goes dark, then bright again. Just this is a much lower frequency than the 60Hz refresh flicker. Of course, if it were obvious that "flicker" is the right word to plop into Google, you'd not really need to ask here.
    – derobert
    Mar 24, 2014 at 21:22

2 Answers 2

4

There are several Intel drivers options which, if they don't work perfectly with your hardware, can cause issues like this:

  • The big one is lvds_downclock, but it defaults to off. If you've changed that default, that's the first one to try. (It's possible some kernel versions defaulted to on, so its worth a try to force-disable it).
  • i915_enable_fbc can cause various display issues. The default is per-chip, you may want to try turning it off.

Both of the above will probably increase power usage a little.

  • Finally, powersave defaults to true, turning it off will disable a bunch of powersaving stuff at once. This will probably work, but you'll notice the battery life hit.

There are two ways to set these values:

  1. On the kernel command line, like this: i915.i915_enable_fbc=0. Yes, you need the i915. prefix, even when the option name starts with i915. You can test temporarily by editing the command line in GRUB before booting, and set permanently in the grub config (edit /etc/default/grub, then run update-grub. Or dpkg-reconfigure grub-pc).
  2. Create a new file in /etc/modprobe.d, for example /etc/modprobe.d/local-i915.conf. Then inside it, put options i915 i915_enable_fbc=0 lvds_downclock=0 (etc.). Note that you do not use the i915. prefix here. After editing, run update-initramfs -u.

Another option is to try a newer kernel. Currently, Debian Backports has 3.12. Newer kernels have fixed a lot of bugs in the Intel video driver, and also have better knowledge of when which hardware particular powersaving features work on.

4
  • Thanks! I've tried this way and it's seems good. Now the black screens comes very rarely, but sometimes they come back. There are some other drivers to add to black list?!
    – Bau Miao
    Feb 27, 2014 at 10:36
  • @BauMiao I don't think there are any drivers to blacklist, it's not like nVidia or ATI where there are both open and proprietary drivers. I'd suggest either trying a newer kernel or check modinfo i915 to see other parameters you can tweak.
    – derobert
    Feb 27, 2014 at 15:29
  • @BauMiao e.g., I'd try Linux 3.12 from backports.debian.org
    – derobert
    Feb 27, 2014 at 17:23
  • Thanks again. Your reply is extremely clear! I will try with a new kernel...
    – Bau Miao
    Feb 28, 2014 at 7:42
0

Apparently this is a common problem with Linux and Intel chipsets. If you have i915 chipsets and Grub, try editing /etc/default/grub and adding i915.enable_psr=0 to the GRUB_CMDLINE_LINUX_DEFAULT line. E.g., GRUB_CMDLINE_LINUX_DEFAULT="foo bar i915.enable_psr=0". Then run command update-grub and reboot.

1
  • Rather: grub-mkconfig -o /boot/grub/grub.cfg
    – Florian
    Sep 6, 2016 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.