Red Hat 5/6 when I do mount it says type nfs, I would like to know how to determine version if it isn't listed in mount options or fstab. Please don't say remount it with the version option, I want to know how to determine the currently mounted NFS version. I am guessing it will default based on NFS server/client settings, but how to I determine what it is currently? I am pretty sure it's NFS v3 because nfs4_setfacl is not supported it seems.


Here are 2 ways to do it:


Using mount's -v switch:

$ mount -v | grep /home/sam
mulder:/export/raid1/home/sam on /home/sam type nfs (rw,intr,tcp,nfsvers=3,rsize=16384,wsize=16384,addr=


Using nfsstat -m:

$ nfsstat -m | grep -A 1 /home/sam
/home/sam from mulder:/export/raid1/home/sam
 Flags: rw,vers=3,rsize=16384,wsize=16384,hard,intr,proto=tcp,timeo=600,retrans=2,sec=sys,addr=mulder
|improve this answer|||||
  • 1
    Worth noting, sometimes nfsstat -m shows version and more details when mount -v does not. – bbodenmiller Mar 10 '17 at 8:54

Use nfsstat -m it will display all the nfs mounted filesystem and theirs properties.

|improve this answer|||||
  • 2
    I liked your answer but gave it to slm because he provided more information. – Gregg Leventhal Feb 19 '14 at 16:31
  • I upvoted this answer because it contained less information, and answered the question perfectly. – Janac Meena Nov 26 '18 at 21:45

Don't forget the ultimate authority!

cat /proc/mounts
|improve this answer|||||

In Ubuntu 12.04, mount -v has the same information than without -v (no NFS version).

nfsstat -m shows the information about version.

|improve this answer|||||

Just plain


On the master server worked for me --

Server nfs v3:

Using -m only worked on the slaves

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.