I have 4 hard disks (I am on Debian LiveCD now):

user@debian:~$ sudo blkid
/dev/sda1: LABEL="System Reserved" UUID="EE2CE1122CE0D71D" TYPE="ntfs" 
/dev/sda2: UUID="AEB0F4D6B0F4A64D" TYPE="ntfs" 
/dev/sda3: LABEL="WINYANCI" UUID="40BCF0AABCF09B9A" TYPE="ntfs" 
/dev/sdb5: LABEL="YAHSI" UUID="8efb4a53-f0fd-4e24-8217-1f27dff3d2b5" TYPE="ext4" 
/dev/sdc2: UUID="5c65c579-a385-4d89-b979-04c2c182d040" TYPE="swap" 
/dev/sdc3: UUID="c9a6ef89-c1b6-4827-8e3c-2ec39fcb1265" TYPE="ext4" 
/dev/sdc4: UUID="110b5c0c-cd0e-4284-99a5-61fe02c217ec" TYPE="ext4" 
/dev/sdc5: UUID="6ec4938a-71a7-4ea1-a9e6-9ed0c90c4a45" TYPE="ext4" 
/dev/sdc6: UUID="5D641D223A2A64B4" TYPE="ntfs" 
/dev/sdd2: LABEL="DEPO" UUID="02D8A6A9D8A69A85" TYPE="ntfs" 
/dev/sdd5: LABEL="HUSUSI" UUID="E0949947949920D8" TYPE="ntfs" 
/dev/sr0: LABEL="Debian wheezy 20140209-18:05" TYPE="iso9660" 
/dev/loop0: TYPE="squashfs" 

sdc is the new 1 TB hard disk, sda is where I have Windows 7 installed (and the old GRUB in MBR from my previous Debian installation) and sdb and sdd are just storage. Since I've bought a new shiny disk and I wanted to use GPT on my new disk and then partitioned it like this:

user@debian:~$ sudo gdisk /dev/sdc                                                                                                                                                                                                                                             
GPT fdisk (gdisk) version 0.8.5                                                                                                                                                                                                                                                

Partition table scan:                                                                                                                                                                                                                                                          
  MBR: protective                                                                                                                                                                                                                                                              
  BSD: not present                                                                                                                                                                                                                                                             
  APM: not present                                                                                                                                                                                                                                                             
  GPT: present                                                                                                                                                                                                                                                                 

Found valid GPT with protective MBR; using GPT.                                                                                                                                                                                                                                

Command (? for help): p                                                                                                                                                                                                                                                        
Disk /dev/sdc: 1953525168 sectors, 931.5 GiB                                                                                                                                                                                                                                   
Logical sector size: 512 bytes                                                                                                                                                                                                                                                 
Disk identifier (GUID): 2758BB06-C7E7-451B-9C92-F1B278721BB6                                                                                                                                                                                                                   
Partition table holds up to 128 entries                                                                                                                                                                                                                                        
First usable sector is 34, last usable sector is 1953525134                                                                                                                                                                                                                    
Partitions will be aligned on 2048-sector boundaries                                                                                                                                                                                                                           
Total free space is 3437 sectors (1.7 MiB)                                                                                                                                                                                                                                     

Number  Start (sector)    End (sector)  Size       Code  Name                                                                                                                                                                                                                  
   1            2048            6143   2.0 MiB     EF02                                                                                                                                                                                                                        
   2            6144         8394751   4.0 GiB     8200                                                                                                                                                                                                                        
   3         8394752        76754943   32.6 GiB    EF00                                                                                                                                                                                                                        
   4        76754944       174409727   46.6 GiB    0700  
   5       174409728      1346283519   558.8 GiB   0700  
   6      1346283520      1953523711   289.6 GiB   0700

Then I went on to install Debian on sdc3 (which is /, sdc4 is /home). Installer asked me if it should install GRUB on MBR of sda. I said 'no' because there is a 2 MiB partition with grub_bios flag on sdc (since my old motherboard doesn't have UEFI) and I wanted to install GRUB there: iTried

Now, GRUB won't boot! Either it conflicts with the 'old' GRUB in sda's MBR (I thought, when I said GRUB to install on sdc there would be only one GRUB on sdc's GPT) or I failed to install GRUB correctly or installing it on sdc5 was completely stupid while I should have installed it on sdc1 or somewhere else on sdc... Any ideas how to solve this? grubError

PS: I have tried to reinstall GRUB reading this tutorial but again the same error (this time I chose /dev/sdc as the location to install GRUB).


you have not updated grub and grub tries to boot the 4ccef65b-... device which doesn't exist.

You can choose between

  • when the boot screen appears type e for edit. In the linux boot line change the 4cce... with roo=/dev/sdc3 or whatever your root partition is. If your system is up, run update-grub.

  • the hard way, is to boot from a rescue pen-drive, mount your root and chroot (like explained in step 3 of your howto).

Useful links:

  • Both ways didn't work. So as a final attempt I inserted the Win7 dvd and made a /FixMbr. Now GRUB boots. Though I have no idea how this worked. – şaloma Feb 20 '14 at 2:06
  • 1
    According to bootinfoscript, GRUB is installed on sda, sdc and sdd (paste.debian.net/hidden/e1e3a423). I guess that's messed up. What should I do? – şaloma Feb 20 '14 at 3:12
  • I inserted some links to the post, hope it will help. – user55518 Feb 20 '14 at 12:29
  • @Infestor the paste.debian link is broken – Fernando Kosh Jul 1 '15 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.