4

I just installed Debian 7.4 in a VMware machine. On first boot, it gave me the following error:

GNOME 3 Failed to load

GNOME 3 Failed to Load

Unfortunately GNOME 3 failed to start properly and started in the
fallback mode.

This most likely means your systeam (graphics hardware or driver) is not
capable of delivering the full GNOME 3 experience.

Then, I noticed that 3D acceleration was disabled in my VM settings, so I enabled it and restarted the VM. I still got the same error.

I noticed that the default resolution was 800x600 for some reason, so I increased that and rebooted. This time, I didn't get the error, but I still don't see GNOME 3.

What am I doing wrong and how can I fix all this and get GNOME working under VMware?

I am running this on a mid-2011 iMac with an AMD/ATi Radeon HD 6750M 512MB and 16GB of system RAM, so it certainly can't be due to the host system limitations.

  • 1
    Two things. First, to diagnose the issue, look at ~/.xsession-errors where ~ is the home directory of the user account you use to log in. Second, my guess is, all you need to do is install guest additions. – Joseph R. Mar 6 '14 at 23:00
2

The problem is that the graphics driver xserver-xorg-video-vmware was compiled without 3D acceleration support. This has already been fixed for newer releases, and is in debian jessie.

The Solution
Recompile the package with 3D acceleration support

  1. install dependencies for VMware Tools
    sudo apt-get install linux-headers-$(uname -r) make gcc

  2. Install the dependencies and build the driver package
    mkdir tmp && cd tmp
    sudo apt-get install libxatracker-dev
    sudo apt-get build-dep xserver-xorg-video-vmware
    sudo apt-get source xserver-xorg-video-vmware -b
    sudo dpkg -i xserver-xorg-video-vmware*.deb

  3. Reboot the machine

If that did not work, try these additional steps:

  1. mount the VMware tools cdrom and install VMware Tools
    sudo mount /dev/cdrom /media/cdrom
    tar xvzf /media/cdrom/VMwareTools-9.6.1-1378637.tar.gz
    cd vmware-tools-distrib
    sudo ./vmware-install.pl -d

  2. Reboot the machine

  • Thanks for the suggestion. I haven't actually gotten the time to try it out yet, but I will soon and let you know. – aalaap Nov 19 '14 at 19:50
  • I think a fresh new 7.7 install and enabling 3D as well as 2D acceleration has done the trick, in addition to installing the guest additions. – aalaap Nov 21 '14 at 16:13
  • First option worked for me on a vanilla install of Debian 7.8.0-i386 on VMWare Workstation 9! – voetsjoeba Jan 18 '15 at 1:11

protected by Community Apr 9 '15 at 12:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.