1

I run Linux Mint 14. I bought a wacom intuos pen&touch small tablet and my old driver (don't know which one, someone installed it for me...) does not support it.
I did a little research and found input-wacom which I tried to install (I'm pretty new to linux but I found some clear instructions on http://sourceforge.net/apps/mediawiki/linuxwacom/index.php?title=Input-wacom . Everything went right, but when I tried to copy the .ko files with the following commands

sudo cp ./<kernel version>/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet
sudo cp ./<kernel version>/wacom_w8001.ko /lib/modules/`uname -r`/kernel/drivers/input/touchscreen

the terminal returned nothing. I went to my /lib/modules/2.5.0-17-generic/kernel/drivers/input/tablet directory and noticed that there already was a wacom.ko file, but it's older than the wacom.ko file in the input-wacom(...) folder. So I have the old driver installed, but I can't find a way to uninstall it nor replace the wacom.ko files—when I use the command, nothing happens, and when I try to replace it using the explorer, I don't have the right permissions to do it.

So here I am, stuck with two drivers, and of course my tablet is not working. How can I solve the problem?

1 Answer 1

0

With Kernel modules (drivers) you typically unload them like so:

$ sudo rmmod wacom

You can see what modules are installed with this command:

$ lsmod

You can filter that output like this:

$ lsmod | grep -i wacom

To install a module you use the insmod command like so:

$ insmod wacom

You can confirm that the system is "seeing" your newly installed module using the modinfo command like so:

$ modinfo wacom
filename:       /lib/modules/3.12.9-201.fc19.x86_64/kernel/drivers/input/tablet/wacom.ko
license:        GPL
description:    USB Wacom tablet driver
author:         Vojtech Pavlik <[email protected]>
license:        GPL
description:    USB Wacom tablet driver
author:         Vojtech Pavlik <[email protected]>
alias:          usb:v17EFp6004d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v056Ap00FAd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v056Ap00F6d*dc*dsc*dp*ic03isc00ip00in*
...
...
depends:        
intree:         Y
vermagic:       3.12.9-201.fc19.x86_64 SMP mod_unload 
signer:         Fedora kernel signing key
sig_key:        EE:42:35:0B:76:0C:ED:24:D6:16:92:81:FB:20:8E:24:05:25:F6:EE
sig_hashalgo:   sha256
3
  • @MasterOfPotatoes - terrific. Please mark this as accepted so everyone else knows your issue's been resolved.
    – slm
    Commented Feb 18, 2014 at 20:23
  • Right, sorry, first time I post something here, I didn't notice that small button... Commented Feb 19, 2014 at 1:23
  • @MasterOfPotatoes - NP, most ppl don't notice it 8-), hence why I usually let them know. Don't be stranger stay around the site, and thanks for the accept!
    – slm
    Commented Feb 19, 2014 at 1:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .