9

Using Linux mint 16, with XFCE as desktop environment. I have a problem removing the default keyboard shortcut (Super_L), for opening the Whisker menu.

The shortcut shows up in Application shortcuts, in the keyboard settings.Though, as shown in the image below, I am not able to remove it by clicking remove - nothing happens.

shortcut

I have also tried modifying ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml to no avail. I can not seem to find an entry for the xfce4-whiskermenu-plugin.

Even uninstalling the Whisker menu does not work.

So my question is, how do I stop the Whisker menu from hijacking my Windows/Super_L key? I want to bind this key to another application launcher.

  • Have you tried reset to defaults? Of course you'd need then to recreate the other shortcuts. – landroni Feb 26 '14 at 16:56
  • Reset to defaults seems to clear the shortcuts at first. Though after reopening the keyboard settings, everything is back, including the Super_L shortcut. – Morgan Bengtsson Feb 26 '14 at 20:52
  • A shot in the dark: Have you tried logging-in/-out? And a Reset to defaults in between? – landroni Feb 26 '14 at 21:00
  • I am very curious about the theme you are using here. By the way, updating /usr/share/mint-configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml, as per @Stepan's answer works. Thank you. – ivan-k Nov 13 '14 at 20:19
  • @Manbroski that would be the Uncomplicated theme. – Morgan Bengtsson Nov 14 '14 at 21:25
7

You have to edit as a root /usr/share/mint-configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml and comment out or delete this tag:

<property name="Super_L" type="string" value="xfce4-popup-whiskermenu"/>

Then logout and login.

  • I also had to delete the Super_L line in /home/USER/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml to get this solution to work. – user8547 Oct 25 '14 at 0:31
2

I've had the same problem in Linux Mint 17 XFCE, and the only solution I've found so far was to:

  • Uninstall xfce4-whiskermenu-plugin
  • Log out
  • Reinstall xfce4-whiskermenu-plugin <-- this step is vital!

The entry with Super L will still show up in the Application shortcut window, but it is actually disabled.

I hope it works for you too.

  • Thanks for the tip. It was not needed on Linux mint 17.2 XFCE edition. There, I found that the Super_L shortcut does appear in the keyboard shortcut list, can be removed and has the intended effect, permanently. – Stéphane Gourichon Nov 4 '15 at 18:01
0

I had similar problem. Actually I couldn't even change my shortcuts from the Window Manager -> Keyboard. The settings didn't save after I close the Window Manager. My solution was to remove (or just move) the Linux Mint's shortcut settings:

mv /usr/share/mint-configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml{,.BAK}

and work with only the default XFCE keyboard shortcut configurations:

/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/home/user/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml  

Note: You must log out in order changes to take effect.

protected by Community Dec 11 '14 at 5:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.