I usually use kate as my preferred text editor, however, whenever I open it there are no window borders, and thus no maximize, minimize, and close buttons. How can I fix this?

I tried going thought the view menu, but was unable to find any settings to alter this.

Moreover, it seems to be stuck in "always on top mode" and thus I cannot view my panel to use right click to close or modify it.

Pressing F11 produces no change.

There is a scroll bar, but it doesn't appear to be controlled by the window manager (kwin) as it is much wider than normal and has a mini preview of the entire document as its background. I'd prefer not to override this feature if possible.

I have an almost default install of Linux Mint KDE 16 x64.

Related: How do I exit full screen after enabling via the right click context menu of kwin (KDE)?

  • A temporal workaround: Alt+RightClick inside the window; that should give you a list of commands (Min/Max/Always on top...)
    – aularon
    Feb 17, 2014 at 14:04
  • @aularon it does not :(
    – virtualxtc
    Feb 17, 2014 at 14:05
  • If your installation is new, is it the same for your ~/.kde folder ? I kept the same one from KDE 4.0 to KDE 4.11, and I solved MANY problems by finally erasing it.
    – kursus
    Feb 17, 2014 at 14:40
  • @kursus I'm not sure I understand what you are asking; I didn't migrate an old ~./kde I think I actually changed a setting in kate to make it go full screen, but then never figured out how to undo it.
    – virtualxtc
    Feb 17, 2014 at 14:43
  • 1
    Ok that was pretty much my question. Be aware that the fullscreen shortcut in Kate is ctrl+maj+F and not F11 like many other KDE apps.
    – kursus
    Feb 17, 2014 at 15:05

2 Answers 2


This will happen if you:

  • right click on the kate window border or it's entry in the task manager bar
  • select 'more actions' -> 'Full screen'


  • press ctrl-shift-F

I originally solved this by:

  • removing katerc from ~/.kde/share/config

This is best undone by:

  • pressing ctrl-shift-F

I had the same issue with gwenview. After entering-exiting fullscreen mode all window features (minimize, maximize,resize,exit e.t.c) disappeared. The solution was to remove ~/.config/org.kde.gwenviewrc. Search for kate related files in ~/.config. find ~/.config -name "*kate*" ~/.config/katerc ~/.config/katevirc ~/.config/katepartrc Cleaning resource files may help: mv ~/.config/katerc ~/.config/katerc.bak

  • I wonder what feature/bug causes this obnoxious behaviour.
    – ajeh
    Jul 8, 2018 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.