2

I created 2 test folders:

mkdir /home/oshiro/Desktop/encrypted
mkdir /home/oshiro/Desktop/decrypted

oshiro@debian:~/Desktop$ ls -l
total 8
drwxr-xr-x 2 oshiro oshiro 4096 Feb 15 20:34 decrypted
drwxr-xr-x 2 oshiro oshiro 4096 Feb 15 20:33 encrypted

I installed encfs:

sudo aptitude install encfs

I then tried using encfs with the 2 folders I created above:

oshiro@debian:~/Desktop$ encfs /home/oshiro/Desktop/encrypted /home/oshiro/Desktop/decrypted

Creating new encrypted volume.
Please choose from one of the following options:
 enter "x" for expert configuration mode,
 enter "p" for pre-configured paranoia mode,
 anything else, or an empty line will select standard mode.
?> p

Paranoia configuration selected.

Configuration finished. The filesystem to be created has
the following properties:
Filesystem cypher: "ssl/aes", version 3:0:2
Filename encoding: "nameio/block", version 3:0:1
Key Size: 256 bits
Block Size: 1024 bytes, including 8 byte MAC header
Each file contains 8 byte header with unique IV data.
Filenames encoded using IV chaining mode.
File data IV is chained to filename IV.
File holes passed through to ciphertext.

New Encfs Password: 
Verify Encfs Password: 

But then I got this error:

fuse: failed to open /dev/fuse: Permission denied
fuse failed. Common problems:
- fuse kernel module not installed (modprobe fuse)
- invalid options -- see usage message
oshiro@debian:~/Desktop$ 

I've configured encfs on Ubuntu 12.04 without any issues, I had an issue on CentOS 6.5 which I corrected by running:

sudo chmod +x /usr/bin/fusermount

but that was for a slightly different error message. I tried the same command on Debian 7.4, but it made no difference. Anyone know how to get this to work?

2 Answers 2

4

Solution:

usermod -aG fuse <your-username>
reboot
1
  • 1
    You do not need to reboot for group changes to take effect. Simply logging out and back in will suffice.
    – phemmer
    Feb 16, 2014 at 11:11
1

oshirowanen's anwser was not enough for me on Debian 7.8. I did the following, and now it works:

Verify that the module is loaded:

$ lsmod | grep fuse
fuse                   62012  2 

The output above shows it's loaded. If the output is empty, load the module:

sudo modprobe fuse

Add yourself to the fuse group:

usermod -aG fuse <your-username>

Change the permissions on the fusermount binary so it's suid group too, instead of just suid user:

chmod 6755 /bin/fusermount

I also changed the permissions on /dev/fuse, but this is probably not required:

chmod g+rw /dev/fuse
chmod o+rw /dev/fuse

I can now succesfully mount using encfs as a normal user:

$ encfs ~/.documents/ ~/NewDocuments/
EncFS Password: 
$ 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .