4

OS: Linux Mint

The output of inxi -xG:

Graphics:  Card: NVIDIA GF108 [GeForce GT 440] bus-ID: 02:00.0 
          X.Org: 1.13.0 drivers: vesa (unloaded: fbdev) Resolution: 
800x600@0.0hz 
         GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits) GLX
Version: 2.1 Mesa 9.2.0 Direct Rendering: Yes

Intend to flip the PC's screen. Above information about current graphics card and operating system.

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 400, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
  800x600         0.0* 
  640x480        60.0  
  640x400         0.0  
  320x400         0.0 

So far, I've tried to follow the available tips on the internet, unsuccessfully. My main suspicion is about the Nvidia driver. Can anyone shed light over this issue?

This command: xrandr -o rotate doesn't work.

2

You need to use --rotate in newer versions of xrandr not the -o switch.

Examples

$ xrandr --output LVDS1 --rotate left
$ xrandr --output LVDS1 --rotate right
$ xrandr --output LVDS1 --rotate normal

What's my output?

You can find out your display's name using xrandr without any arguments.

$ xrandr
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 8192 x 8192
LVDS1 connected primary 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
   1440x900       60.0*+   50.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)

NVidia cards

With this graphics card you'll likely need to add this to your "Device" section of your xorg.conf file.

Option    "RandRRotation" "True"

You'll have to restart X11 to get this change to take effect. After doing so xrandr you should be able to rotate your display.

References

0

Update your xorg-server package. Timo Aaltonen has fixed this issue.

xorg-server update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.