I'm trying to use a CD on CentOS 6.4, but I keep getting this error:

Unable to mount Disc Error mounting: mount: unknown filesystem type 'udf'

I've installed udftools

I've tried changing the permissions around on /dev/sr0 to no avail.

I've tried various ways of mounting the disc such as:

  • mount /dev/sr0 /mnt (unknown filesystem type 'udf')
  • mount -t auto /dev/sr0 /mnt (unknown filesystem type 'udf')
  • mount -r -t iso9660 /dev/sr0 /mnt (wrong fs type...)
  • mount -t udf /dev/sr0 /mnt (unknown filesystem type 'udf', despite being in the man page for mount)
  • dd if=/dev/sr0 of=disc.iso -> mount -o loop disc.iso /mnt -t iso9660

I can see and read from the disc just fine in a VM on that host and on other physical machines.

It also seems to happen with just about every disc that I've tried.

Any thoughts?

  • Are you mounting as your username or as root?
    – slm
    Commented Feb 14, 2014 at 22:46
  • Also please provide the output from wodim: wodim dev=/dev/sr0 --scanbus. If that doesn't work try this: ` wodim -prcap`.
    – slm
    Commented Feb 14, 2014 at 23:59
  • 1
    BTW this is happening as root Commented Feb 16, 2014 at 0:01

4 Answers 4


I've figured out the issue. Someone had added a line in this file:


that said:

install udf /bin/false

I simply commented it out, and I'm now able to mount discs.


I had the same issue, but it got disabled by a CIS security baseline setting located at the following location:


Commented the install udf /bin/true line and it worked.


I got the same error message. Checked /etc/modprobe.d and found a file called usgcb.blacklist. In there it had.....

install udf /bin/true 

Commented it out and now our system can read a CD-ROM

  • Welcome to StackExchange @TR55! Would you be able to provide information on what does that configuration does? It is not clear to what happens if your advice is followed.
    – Zip
    Commented Dec 23, 2019 at 20:36

You don't say this but I get the impression you're attempting to mount the DVD drive using just your regular userid, which typically is not allowed to make use of the mount command as you're attempting to do so.

To mount using mount you typically need to be root or have sudo privileges to do this:

$ sudo mount -t udf /dev/sr0 /mnt

This command should typically "just work" on most Linuxes. Occasionally you might need to do it like so:

$ sudo mount -t udf /dev/dvd /mnt

Drive capabilities

If you're not having any luck you can check your drives capabilities using the command line tool wodim.

$ wodim -prcap
wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
Device was not specified. Trying to find an appropriate drive...
Detected CD-R drive: /dev/sr0
Using /dev/cdrom of unknown capabilities
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : 'Optiarc '
Identification : 'DVD RW AD-7930H '
Revision       : '1.D1'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.

Drive capabilities, per MMC-3 page 2A:

  Does read CD-R media
  Does write CD-R media
  Does read CD-RW media
  Does write CD-RW media
  Does read DVD-ROM media
  Does read DVD-R media
  Does write DVD-R media
  Does read DVD-RAM media
  Does write DVD-RAM media
  Does support test writing


  • Thanks, I'll take a look at it on Tuesday when I'm back on site. Commented Feb 15, 2014 at 23:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .