1

(The problem that nslookup works but other applications can't resolve name is asked very often, mainly for windows. I read a lot of these answers but none of them was applicable.)

I use OpenBSD with the adsuck deamon. I start adsuck with

cp /etc/resolv.conf /var/adsuck/files
echo "nameserver 127.0.0.1" > /etc/resolv.conf
/etc/rc.d/adsuck start

The deamon is running with two process from user _adsuck:

/usr/local/sbin/adsuck -c /var/adsuck -f /files/resolv.conf -r /files/regex /files/hosts.small
adsuck: [resolv monitor] (adsuck)

I can resolve names with nslookup or dig, but ping or browser does not work. What can be the problem?

(I tried addresses which should not be blocked by adsuck like www.google.com)

Edited:

I should have looked in /var/log/daemon earlier, adsuck had complained about the line

::1 localhost #[IPv6]

in /var/adsuck/files/hosts.small, now adsuck seems to work fine.

But I still do not understand why nslookup had worked when DNS for other applications did not.

1 Answer 1

0

nslookup doesn't use the base resolver libraries, it uses its own. Those mechanisms that often act a bit differently from the base resolver routines. It can be "fun" when you are using it to test and don't know that.

I think that is why they had the push for deprecating the utility several years back.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .