2

When I try to hibernate with systemctl hibernate, the unit systemd-hibernate.service enters failed state and I get the following entries in my journal:

Feb 09 14:18:14 pike systemd[1]: Starting Sleep.
Feb 09 14:18:14 pike systemd[1]: Reached target Sleep.
Feb 09 14:18:14 pike systemd[1]: Starting Hibernate...
Feb 09 14:18:14 pike systemd-sleep[2284]: Failed to write mode to /sys/power/disk: Operation not permitted
Feb 09 14:18:14 pike systemd[1]: systemd-hibernate.service: main process exited, code=exited, status=1/FAILURE
Feb 09 14:18:14 pike systemd[1]: Failed to start Hibernate.
Feb 09 14:18:14 pike systemd[1]: Dependency failed for Hibernate.
Feb 09 14:18:14 pike systemd[1]: Service sleep.target is not needed anymore. Stopping.
Feb 09 14:18:14 pike systemd[1]: Unit systemd-hibernate.service entered failed state.
Feb 09 14:18:14 pike systemd[1]: Stopping Sleep.
Feb 09 14:18:14 pike systemd[1]: Stopped target Sleep.

Indeed cat /sys/power/disk tells me:

[root@pike ~]# cat /sys/power/disk
[disabled]

My swap looks like this:

[root@pike ~]# swapon -s
Filename                Type        Size    Used    Priority
/dev/dm-0                               partition   16383996    0   -1

It is on the LVM and is called /dev/fedora/swap.

My RAM size is 16248756 bytes, so the image should fit into swap.

Suspend-to-RAM works as expected, and with other distros (Ubuntu, Arch) I was able to hibernate previously.

How can I find out why /sys/power/disk is [disabled]?

1 Answer 1

3

I had to disable UEFI Secure Boot because I needed to use VirtualBox. Incidentally, this also enabled standby. I can now systemctl hibernate and systemctl hybrid-sleep.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .