4

I need to install an older version of JBoss. 6.1.0 EAP is what has been approved and supported for my application. So when I try to force install the correct version of the jboss as packages the install fails. A number of times in the dependency resolution stage I get the following error:

Package shrinkwrap is obsoleted by shrinkwrap-impl-base, but obsoleting package does not provide for requirements

Then at the end I get the following error:

Error: Package: jbossas-modules-eap-7.2.0-8.Final_redhat_8.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms)
       Requires: shrinkwrap >= 1.0.0
       Available: shrinkwrap-1.0.0-14.redhat_1.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms)
           shrinkwrap = 1.0.0-14.redhat_1.ep6.el6
       Available: shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms)
           shrinkwrap = 1.0.0-16.redhat_2.ep6.el6

If I try:

yum install shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch

It changes it to shrinkwrap-impl-base-1.1.2. So I'm not sure the best way to proceed.

Is it possible to force yum to install the 1.0.0 package? If not, is it possible to install shrinkwrap-impl-base then install JBoss and ignore only that dependency? (there are several hundred other dependencies so I don't want to ignore all dependencies.)

Or is there some other solution?

System if RHEL 6.4 with base entitlement and jb-eap-6-for-rhel-6-server-rpms channel installed.

3
sudo yum --setopt=obsoletes=0 install shrinkwrap

Or you can put obsoletes=0 to /etc/yum.conf to make such behavior persistent.

Both ways worked for me on Oracle Linux 6.7.

1

Is your application certified for RHEL6?

If so, this is then a support case; and since you're paying for this, do leverage it first.

If your application isn't certified for RHEL6, then it's a learning opportunity. "Is this certified for RHEL(version)" should be in the first 5 questions you ask about a given product, as you want to be able to use the support you're entitled to!

0

You'd have to confirm first if that older version is even available. I'm on Fedora 19, but you'd run a command similar to this:

$ yum list all shrinkwrap* | expand
Loaded plugins: auto-update-debuginfo, changelog, langpacks, refresh-packagekit
Available Packages
shrinkwrap.noarch                            1.0.0-5.fc19                 fedora
shrinkwrap-descriptors.noarch                2.0.0-0.4.alpha2.fc19        fedora
shrinkwrap-descriptors-javadoc.noarch        2.0.0-0.4.alpha2.fc19        fedora
shrinkwrap-javadoc.noarch                    1.0.0-5.fc19                 fedora
shrinkwrap-resolver.noarch                   1.0.0-0.5.beta7.fc19         fedora
shrinkwrap-resolver-javadoc.noarch           1.0.0-0.5.beta7.fc19         fedora

Downgrading

You can use the yum command downgrade to go down to a specific version.

$ sudo yum downgrade shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch

From the man page:

   downgrade
          Will try and downgrade a package from the version currently 
          installed to the previously highest version  (or  the  specified 
          version).  The depsolver will not necessarily work, but if you 
          specify all the packages it should work (thus, all the simple 
          cases will work). Also  this  does  not  work  for "installonly"  
          packages,  like Kernels. downgrade operates on groups, files, 
          provides, filelists and rpm files just like the "install" command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.