I need to install an older version of JBoss. 6.1.0 EAP is what has been approved and supported for my application. So when I try to force install the correct version of the jboss as packages the install fails. A number of times in the dependency resolution stage I get the following error:
Package shrinkwrap is obsoleted by shrinkwrap-impl-base, but obsoleting package does not provide for requirements
Then at the end I get the following error:
Error: Package: jbossas-modules-eap-7.2.0-8.Final_redhat_8.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms) Requires: shrinkwrap >= 1.0.0 Available: shrinkwrap-1.0.0-14.redhat_1.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms) shrinkwrap = 1.0.0-14.redhat_1.ep6.el6 Available: shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms) shrinkwrap = 1.0.0-16.redhat_2.ep6.el6
If I try:
yum install shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch
It changes it to
shrinkwrap-impl-base-1.1.2. So I'm not sure the best way to proceed.
Is it possible to force yum to install the 1.0.0 package? If not, is it possible to install
shrinkwrap-impl-base then install JBoss and ignore only that dependency? (there are several hundred other dependencies so I don't want to ignore all dependencies.)
Or is there some other solution?
System if RHEL 6.4 with base entitlement and
jb-eap-6-for-rhel-6-server-rpms channel installed.