FreeRDP 1.0.2 has an updated their parameter syntax for "better interoperability with Windows." I had a problem using the old syntax where the clipboard plugin only worked the first time I pasted, and subsequently stopped:

xfreerdp --plugin cliprdr -g 1920x1060 -u Administrator -p xxx n.n.n.n

So I decided to try the new syntax, but I can't seem to get it right. The following:

xfreerdp +clipboard /size:1920x1060 /u:Administrator /p:xxx /v:n.n.n.n

Gives an error:

Warning xf_GetWindowProperty (140): Property 385 does not exist
transport_connect: getaddrinfo (Name or service not known)
Error: protocol security negotiation failure

Any advice?

  • I am on mac with freerdp 1.0.2 and what worked for me was: xfreerdp -f --plugin cliprdr --sec rdp Any other combination always failed. – marcinj Sep 14 at 4:28

The xfreerdp protocol changed how to connect. Try the following example:

xfreerdp +clipboard /u:<username> /v:<hostname> /size:<WxH>

Also, if it is necessary to connect over a different port, add /p: <port> after the <hostname> parameter.

  • 2
    At least in version FreeRDP version 2.0.0-dev (git 6001cb710) the /p: is for password, and for port /port: is used. – erm3nda May 13 '17 at 22:44

I found the best option was to upgrade freerdp following these guidelines:

In Terminal:

$ cd /usr/src
$ git clone git://github.com/FreeRDP/FreeRDP.git
$ cd FreeRDP

$ sudo aptitude install libcunit1-dev libdirectfb-dev xmlto doxygen   \
    libxtst-dev libavutil-dev libavcodec-dev build-essential git-core \
    cmake libssl-dev libx11-dev libxext-dev libxinerama-dev           \
    libxcursor-dev libxdamage-dev libxv-dev libxkbfile-dev            \
    libasound2-dev libcups2-dev libxml2 libxml2-dev                   \
    libxrandr-dev libgstreamer0.10-dev                                \
    libgstreamer-plugins-base0.10-dev libxi-dev                       \

$ sudo cmake -DCMAKE_BUILD_TYPE=Debug -DWITH_SSE2=ON .
$ sudo make
$ sudo apt-get install checkinstall
$ sudo checkinstall make install
$ sudo which xfreerdp
$ xfreerdp --version

Now you should see the new version and the command line should work!


Actually I'm starting to suspect that xfreerdp 1.0.2 doesn't support this syntax style at all. I get the exact same result when using the help switch:

xfreerdp /help
Warning xf_GetWindowProperty (140): Property 387 does not exist
transport_connect: getaddrinfo (Name or service not known)
Error: protocol security negotiation failure

The error indicates to me that it doesn't know what to connect to. It doesn't even realize I'm not asking it to connect to anything. This is all despite the documentation which says to favor this "new" syntax. Curious.

Generally speaking, you can now use both --long-option or /long-option. You should use the new interface now the old interface is just kept for compatibility and will be dropped at some point.

  • Repos for my distro recently updated with 1.2.0. The new syntax actually works now and is indeed required. As of this package version, the other answer is more correct. – isuldor Nov 23 '14 at 20:51

If you are accessing/running this from mac terminal to connect to windows this is what made it work nicely for me

xfreerdp --no-nla --plugin cliprdr -g 1600x1000 -u "your_user_name" your_server_or_ip 
  • Thanks. Which version of xfreerdp did this work on for you? – isuldor Jan 2 '18 at 1:07
  • np, it's older one but that's only which actually woks on mac, the xfreerdp version is 1.0.2 – grepit Jan 2 '18 at 2:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.