18

I am on Debian Pulseaudio 2.0-6.1. Up to now never had any issues with sound.

I made some experiments with remote sinks and now it seems pulse it totally messed up.

I have only one sink. When I restart pulseaudio pactl shows the sink as IDLE. As soon as an application tries to output sound the state changes to SUSPENDED and stays that way. "pactl suspend-sink 0 0" does not change the state. I can only get it to IDLE by restarting pulse and the cycle starts again.

After a reboot the problem persists.

2 Answers 2

26

Have you tried disabling suspend-on-idle in /etc/pulse/default.pa? I change this:

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

to this:

### Automatically suspend sinks/sources that become idle for too long
#load-module module-suspend-on-idle

and then to restart it. There is quite a lot of variation in how people do this but killall pulseaudio has always worked for me (it gets automatically started again).

9
  • It helps me to startup Asus Xonar Essense One. Commented Apr 22, 2016 at 13:30
  • This solution also solved my problem when vlc was reporting "connection refused" errors. Commented Aug 28, 2016 at 0:40
  • 1
    Is there a way to limit this to specific sinks, like the HDMI one? I only have issues with my AVR not recognizing when the audio starts again after a longer pause.
    – DanMan
    Commented Jan 18, 2020 at 22:07
  • Thank you! In case anyone wants to automate this in an installation script: sudo sed 's/load-module module-suspend-on-idle/#load-module module-suspend-on-idle/' /etc/pulse/default.pa -i
    – sezanzeb
    Commented Apr 12, 2022 at 17:16
  • 1
    Maybe anchor the regex to start of line to make it idempotent? Commented Apr 12, 2022 at 17:17
1

SOLUTION: When I installed pipewire-pulse, and it replaced pulseaudio, all the issues resolved.

WHY: In my case, pulseaudio was not working because I had both pulseaudio, pipewire and wireplumber installed and working.

I only installed pulseaudio manually. However, I also installed GSConnect, and after a system update it must have installed pipewire and wireplumber as its dependency.

2
  • pipewire-pulse also fixed Failed to create sink input: sink is suspended. on boot after recent (2022-09) update of ArchLinux.
    – temoto
    Commented Nov 17, 2022 at 20:40
  • did you have to reboot or something else? Doing what sam-brightman suggested helped me while pipewire-pulse didn't.
    – dr0i
    Commented Nov 28, 2023 at 8:27

You must log in to answer this question.