I'm using Debian Mint and my internet has worked everywhere on earth (Home, Mcdonalds, other peoples homes) except at school where I really need it. It will always see the networks and will 'try' to connect but will never be able to do so.

Occasionally it will work if I reboot, and disconnect networking, and reconnect, but only occasionally.

It works perfectly if I dual boot to Windows so it's kinda frustrating.

Power management is off, and Tx power is at 15db.

  • Please, give more detail: What tool do you use for connecting? What types of encryption do the networks you can/cannot connect to use? What are the contents of your /etc/resolv.conf after WiFi connection is established? – rozcietrzewiacz Jul 29 '11 at 9:51
  • do you have to register your mac address with school? maybe windows users get a cute little pop-up when they connect the first time that you aren't getting? – CrackerJack9 Aug 30 '11 at 23:12
  • @adil1011 My School used all kinds of wonderful Cisco special crap to make it hard for me to connect on linux, ( I never did get it). I suspect (but might be wrong) that this has nothing to do with your wireless drivers, and everything to do with their security. Unfortunately, we can't really tell you how to do that, unless you tell us what is done on windows. – xenoterracide Sep 14 '11 at 14:04

Let me guess, you have an atheros (or similarly persnickety) chipset in your wireless card.

The good news is that the unix drivers for those things have gotten way better in the last few years. The bad news is they still have some quirks that are usually overcome in software by the drivers. The proprietary windows drivers take care of this, but the open source ones have trouble learning all the stupid hoops that have to be jumped through to make the hardware behave.

These glitches usually come out when connecting to specific network types or other brand chips. You might find using a different authentication method (can you use fixed keys instead of pass-phrase auth at your school?) may work. Another way to make those things more cooperative is use ndiswrapper to actually load the windows driver in linux.


You must try ndiswrapper if works on windows and not on linux.


I made different experiences with my router, depending on the settings, whether to allow type b, type g or both b/g. I had very unstable connections with the setting 'both'.

But I don't know much about technical details. It's only an idea of what to look for. Maybe an additional USB-WLAN-Stick is the best solution, if you inform yourself, which works natively good with linux - they aren't expensive any more, afaik.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy