1

I'm trying to install Slackware 14 from a DVD. It boots fine from the DVD.

When I try to use fdisk or cfdisk to create the Linux and swap partitions on the SSD, it complains about a missing or unknown partition table.

In either program, if I create the Linux and swap partitions and write them to the disk and then quit, it says disk contents changed and complains about the partition table.

Using either program again still complains and shows no partitions.

I have used Slackware DVDs in the past on hard (spinning) drives with no problem.

  • Have you booted again after working on the partition table? – Marki Feb 10 '14 at 0:15
  • yes, it still complains about the partition table. – Ray Tayek Feb 10 '14 at 0:31
  • Can you post the actual output from this? – slm Feb 10 '14 at 0:35
2

In researching this much of the results I've been finding have pointed to the items I mention in leads #1 & #2. I'm adding some additional leads that might be worth following up on, but I would expect the possibility of anything after lead #3 to be a "hail mary".

Lead #1 - GPT

The first has to do with using GPT HDD partitioning vs. MBR. So I'd suggest trying to use gdisk, parted, or even sgdisk instead.

Lead #2 - Defective SSD or Controller

Another issue that seem to come up was that the message "unknown partition table" will occur when you are encountering either a failing or defective SSD drive, or if the controller that it's connected to is failing. To eliminate the controller you might want to try connecting the SSD to another controller to see if the problem persists.

Lead #3 - Firmware?

A third issue I came across sounded like a far fetched possibility but I'll mention it none the less. Perhaps there is firmware on your SSD that is in need of being updated? This is the thread that I came across, titled: SSD Drive Failing? Remount read-only.

According to the model # you mentioned, "ocz vertex 3 90gb", there does appear to some potential updates available on the OCZ website: http://ocz.com/consumer/download/firmware.

Lead #4 - SSD Identification info

Finally I would take a look at the output of hdparm -i <device> to see if that can shed any light on what's going on with your SSD drive.

$ sudo hdparm -i /dev/sdc

/dev/sdc:

 Model=ST3000DM001-1CH166                      , FwRev=CC43    , SerialNo=            Z1XXXXXX
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=unknown, BuffSize=0kB, MaxMultSect=16, MultSect=?16?
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=268435455
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 
 AdvancedPM=yes: unknown setting WriteCache=enabled
 Drive conforms to: unknown:  ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6 ATA/ATAPI-7

 * signifies the current active mode

Lead #5 - Testdisk

Perhaps the software application testdisk might be able to repair what's wrong with your SSD? This feature is what caught my eye:

  • Fix partition table, recover deleted partition

Lead #6 - HDAT2 or Spinrite

You can run either of these tools on SATA and SSD HDD's. Perhaps one of them can repair what's wrong with your drive? I've had good success with both products in repairing drives that would otherwise not work properly. Note that HDAT2 is freeware, while Spinrite is a commercial product.

Lead #7 - dmesg

Make sure to scrutinize the dmesg log after booting up the system to determine how the SSD device is detected by the Linux kernel. Additional information may be revealed there which might shed light on why the device is acting strangely when attempting to partition it.

| improve this answer | |
  • gdisk says there are none, claims to be making one. writing this out says all is fine, but running gdisk again complains that there are no partition table. – Ray Tayek Feb 10 '14 at 1:15
  • Try poking it with sgdisk too: unix.stackexchange.com/questions/103879/… – slm Feb 10 '14 at 1:42
  • @RayTayek - also what does hdparm -i /dev/... say? – slm Feb 10 '14 at 1:54
  • i create a partition and formatted it under win 8. – Ray Tayek Feb 10 '14 at 2:21
  • @RayTayek - what's the make/model of the SSD? So it's likely a driver issue if Linux cannot see the device. – slm Feb 10 '14 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.