1

I have a Norwegian Lenovo USB keyboard.

When I hold AltGr and press v and b rapidly, it produces “bvbv instead of “”“”“”. I get the latter, expected, result when pressing v and b slowly. Never letting go of AltGr.

xev shows that the AltGr key is released when pressing b for the first time when doing this rapidly. (Output.)

Any idea what could be causing this?

Updated Debian Jessie with GNOME desktop.

0

Aeyoun,

http://www.xfree86.org/4.0/xmodmap.1.html

Have you attempted to correct this by applying an xmodmap to your X11 session?

This will intercept the keys affected, and apply the output you require.

xmodmap -pke > crud

will display your Key-Map to Key-Code bindings.

Determine the Key-Map Identity which are producing incorrect Key-Code Identity bindings.

When you understand the identity of what you are inputting (Key-Map Identity) to Key-Code Bindings, you will be able to set the Key-Map to Key-Code binding appropriately and store it in your X11 session.

You need to modify your .Xinitrc to run these xmodmap commands.

I've personally used xmodmap to disable input keys on "padlocked" systems. You can reconfigure your entire keyboard using this knowledge.

This is the fix. Trust me. Xmodmap will solve it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.