4

I have the following xsession file:

[Desktop Entry]                                                                 
Name=...
Comment=This session will start ...
Exec=????
TryExec=???
Type=????

After choosing my desktop environment and after logging in I want to see a full screen terminal running echo "Hello World" command.

What values have I pass to Exec, TryExec and Type field fields?

I already tried this:

Exec=gnome-terminal --full-screen -x "echo 'hello'"

But the terminal doesn't start in full screen mode. When I run this command in normal session it starts correctly.

  • 1
    Why use a desktop environment? If all you need is a full screen terminal, just boot to the command line. Anyway, Type and TryExec aer not important. You need to set up a script that launches the terminal as you like and give that script to Exec. This would be easier to answer if you explained what your final goal is. As it stands, your question doesn't make much sense. – terdon Feb 9 '14 at 15:09
  • @terdon Because I am testing how the xsession works. I tried: Exec=gnome-terminal --full-screen -x "echo 'hello'" - but the terminal doesn't start in full screen mode. When I run this command in normal session it starts correctly. – Ionică Bizău Feb 9 '14 at 15:15
  • Well, yes, you also need to start some kind of window manager that can display stuff full screen. Also, remember to mention what you've tried in your question. It helps us understand and shows that you've done your homework. – terdon Feb 9 '14 at 15:18
  • @terdon Would it be possible to start something like the non-gui terminal? – Ionică Bizău Feb 9 '14 at 15:22
  • Yes, that's what I meant by my first comment. Have a look at this. – terdon Feb 9 '14 at 15:26
1

The --full-screen switch is supported by the window manager, i.e. the terminal sets a hint that the window should be expanded to cover the entire screen, and the window manager is responsible for appropriately resizing it.

Thus, you need to start both a window manager that respects the fullscreen hint and the terminal.

  • Ok, how can I start the window manager, but only the terminal will appear on entire screen? However, the shortcuts should be disabled. What about starting it as tty or something like that? – Ionică Bizău Oct 8 '14 at 15:17
  • 1
    Normally the window manager is started by the session manager, gnome-session, but nothing stops you from starting it yourself as a background task (x-window-manager & followed by your terminal invocation). You might want to use a window manager with less functionality, or even something similar to ratpoison. – Simon Richter Oct 8 '14 at 16:01
  • It doesn't work. However, ratpoison is something interesting. – Ionică Bizău Oct 8 '14 at 16:34
  • When adding x-window-manager & to the script file that I want to run it's working. :-) So, +1 for now and waiting how can this be improved. I also want to remove any shortcuts for gnome-terminal session (like ctrl + shift + t === new tab etc). – Ionică Bizău Oct 8 '14 at 16:40
  • 1
    Would a regular xterm work for you as well, or does it have to be gnome-terminal? – Simon Richter Oct 8 '14 at 20:41
0

Try this Exec=bash -c ' sleep 30; gnome-terminal --full-screen -x "echo hello'" ; sleep 20 .
Also note any time (before/after login) you can press ctrl+alt+F1 to F6 to launch a tty, which is a full screen terminal. You can login from there.

  • This doesn't work for me... :-/ – Ionică Bizău Oct 13 '14 at 6:49
  • Can you open a tty by pressing <kbd>ctrl</kbd>+<kbd>alt</kbd>+<kbd>F6</kbd> before or after login to x – totti Oct 15 '14 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.