3

Instead, I get a plain shell prompt log-in. After logging in, I try gdm start but get this:

# gdm start
** (gdm-binary:977): WARNING **: Failed to acquire org.gnome.DisplayManager 
** (gdm-binary:977): WARNING **: Could not acquire name; bailing out
#

I have installed via pkg install gnome2, added the root user and a non-root user to the wheel group, and set up rc.conf, fstab, and .xinitrc - all as specified in the basic gnome2 instructions for setting up to start via gdm.

7
  • Need more info about how you setup the VM in virtualbox. Since the setup there is likely why this isn't working now. Go through settings such as how much RAM and video options you selected for the VM. If they aren't right then what you're experiencing is what you'll get.
    – slm
    Feb 8, 2014 at 21:52
  • Display is set to 128MB RAM (the maximum allowed by the virtual box "Settings" user interface), Monitor Count is set to 1, and Extended Features is set to Enable 3D Acceleration. Base Memory is set to 2048 MB. Chipset is PIIX3. Feb 8, 2014 at 22:21
  • The boot-up log shows the message gdm started with no associated errors or warnings. Also, I tried turning off 3D Acceleration and restarting, but that did not change anything. Feb 8, 2014 at 22:30
  • Can you type startx there?
    – slm
    Feb 8, 2014 at 22:35
  • I found this thread: forums.virtualbox.org/viewtopic.php?f=5&t=14693
    – slm
    Feb 8, 2014 at 22:37

1 Answer 1

3

In my case, after I had followed all the current available guides, I still had to pkg install xorg. That fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .