1

I want install Argos 0.5 to Debian 3.12.6-2 (2013-12-29) x86_64 GNU/Linux. I had to install gcc 3.4 because Argos call for it. Now I have gcc 3.4 and gcc 4.8.2-2 too. Problem is that ./configure script gives this error:

The error log from compiling the libSDL test is:
/usr/bin/ld: cannot find -lgcc_s
collect2: ld returned 1 exit status
ERROR: ARGOS requires SDL or Cocoa for graphical output
To build ARGOS without graphical output configure with --disable-gfx-check
Note that this will disable all output from the virtual graphics card.

I have installed libsdl and Cocoa with apt-get. But I have the same problem still. If I search libgcc: find /usr/ -name libgcc* I get this output:

/usr/lib/x86_64-linux-gnu/libgccpp.so.1
/usr/lib/x86_64-linux-gnu/libgccpp.so.1.0.3
/usr/lib/gcc/x86_64-linux-gnu/4.6/libgcc_eh.a
/usr/lib/gcc/x86_64-linux-gnu/4.6/libgcc_s.so
/usr/lib/gcc/x86_64-linux-gnu/4.6/libgcc.a
/usr/lib/gcc/x86_64-linux-gnu/4.7/libgcc_eh.a
/usr/lib/gcc/x86_64-linux-gnu/4.7/libgcc_s.so
/usr/lib/gcc/x86_64-linux-gnu/4.7/libgcc.a
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/libgcc_s_32.so
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/libgcc_eh.a
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/libgcc_s.so
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/32/libgcc_s_32.so
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/32/libgcc_eh.a
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/32/libgcc_s.so
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/32/libgcc.a
/usr/lib/gcc/x86_64-linux-gnu/3.4.6/libgcc.a
/usr/lib/gcc/x86_64-linux-gnu/4.8/libgcc_eh.a
/usr/lib/gcc/x86_64-linux-gnu/4.8/libgcc_s.so
/usr/lib/gcc/x86_64-linux-gnu/4.8/libgcc.a
/usr/lib/ure/lib/libgcc3_uno.so
/usr/share/doc/libgcc-4.7-dev
/usr/share/doc/libgcc1
/usr/share/doc/libgcc-4.8-dev
/usr/share/lintian/overrides/libgcc1

How can I solve this problem?

I have tried compile this simple program with gcc-3.4.

// program.c
#include <stdio.h>

int main() {
 printf("Hello, world!\n");
 return 0;
} 

And I get tis output:

gcc-3.4 program.c
/usr/bin/ld: cannot find -lgcc_s
collect2: ld returned 1 exit status

If I use gcc 4.8.2 everything is ok.

  • How do you know it's using the correct version of gcc? – slm Feb 8 '14 at 14:24
  • The obvious question is - how do you know you are compiling using gcc 3.4? By default, build systems will use the default gcc, which clearly is not 3.4. This may be configurable in your build system - probably a Makefile. I suggest you check this. – Faheem Mitha Feb 8 '14 at 15:13
  • Thanks for replies, configure script writes: /opt/argos-0.5.0/src# ./configure --enable-net-tracker WARNING: "gcc" looks like gcc 4.x Looking for gcc 3.x Found "gcc-3.4" So I thing that this script found correct gcc version. – Mato Feb 8 '14 at 17:30
  • Any other idea please? :-( – Mato Feb 8 '14 at 19:07
  • Did you install 3.4 from source? It is not longer available in recent Debian. If so, this might be a configuration issue. If you want to debug it, try a simple program that tries to link against -lgcc_s. – Faheem Mitha Feb 8 '14 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.