2

I need to run CUDA enabled applications, but (because of other things) I'd rather use Optimus technology rather than running on Nvidia card only. Note that for CUDA I need to use proprietary binary nvidia drivers.

I followed: https://wiki.debian.org/Bumblebee this tutorial (and setup is mostly working). After reboot I can successfully run optirun something command. But after some time I get:

 optirun deviceQuery 
 [ 4574.136296] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card
 [ 4574.136358] [ERROR]Aborting because fallback start is disabled.

I use Quadro K2000M:

  lspci -k 
  01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K2000M] (rev ff)
  Kernel driver in use: nvidia

Here are my questions:

  • Does anyone have pointers how to solve this problem on debian.
  • Is there any guide on manually restarting nvidia card using bbswitch?
  • How can I disable bbswitch at all (losing power management)
0

To anyone interested: I have solved this problem by ditching Optimus altogether and just running on proprietary nVidia drivers. Before that I enabled only nVidia card in BIOS).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.