2

When running headless (without monitor, keyboard, mouse attached) FreeBSD versions 8.2, 8.3, 9.0 and NetBSD version 5.0 has known issues (FreeBSD PR 156596, NetBSD 46596) to generate extremely high interrupt rates. The issue is also known as an interrupt storm and happens when PCI interrupts are shared. Often EHCI is on the same interrupt (#16, irq16) as VGAPCI. Other users reported to have success by attaching a PS/2 keyboard.

The Intel NUC DC3217BY BIOS has no option to disable the onboard video/GPU. We don't need VGA output (headless operation). We do need USB: the boot drive (SDHC card) is attached via a USB bridge.

How can FreeBSD configured to not hit the high interrupts rates, or limit the interrupt rate on ehci0? For example how to disable VGA irq assignment in FreeBSD?

  • 2
    Then follow up the reported bugs... we are very unlikely to give better answers than the experts in charge. – vonbrand Feb 7 '14 at 17:51
  • The reported bugs don't supply a solution, neither a software workaround. A workaround for us could be to limit the interrupt rate on ehci0 or even disable ehci0 completely in FreeBSD. – Pro Backup Feb 7 '14 at 20:47
  • If you're considering workarounds: would attaching a dummy VGA plug help? – Mark Plotnick Feb 7 '14 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.