12

I am running the latest version of Linux Mint with Cinnamon. I'm trying to map Caps Lock to Ctrl, but I cannot figure out how to do it. All web searches I've done have led me to older versions of Linux Mint (there is no keyboard layout option in my settings). How can I do this?

  • 3
    Can you update your question to indicate exactly what the latest version is? This question could be here for years. – Keith Thompson Feb 8 '14 at 0:25
  • As a guide line ... the 'current' Linux Mint release is #18 (~2016), so quoting "the latest" of almost anything in computing is going to rapidly fade the 'factual' colour. (Including this one.) – will Sep 21 '16 at 13:32
15

You can accomplish this with xmodmap. Add the following to ~/.xmodmap:

remove Lock = Caps_Lock
keysym Caps_Lock = Control_L
add Control = Control_L

and run the command xmodmap ~/.xmodmap. You can put this command in whatever startup files are processed by your WM or DE. This will only work in X but it will work regardless of what graphical environment you use.

  • What would be an ideal place for this command for a user of Linux Mint Cinnamon? – Zamicol Jan 12 '15 at 6:55
16

I found it. It was moved to the regional preferences section:

Go to settings > regional preferences > keyboard layouts > settings and expand the caps lock section.

UPDATE:

In Linux Mint 17.1 you can get to it via;

System Settings > Hardware > Keyboard > Keyboard Layouts > Options > Caps Lock key behavior

5

No need to use the obsolete xmodmap as there's already an xkb option - namely ctrl:nocaps e.g. in terminal:

setxkbmap -option ctrl:nocaps

With gnome 3 you can either use dconf-editor and add ctrl:nocaps to your xkb-options under org > gnome > desktop > input sources:

enter image description here

or simply enable Caps Lock as Ctrl in gnome-tweak-tool under Typing > Ctrl key position:

enter image description here

  • setxkbmap -option ctrl:nocaps seems to work well on Debian Jessie, thanks. – Ján Lalinský Jul 4 '17 at 12:42
3

For LinuxMint 17 with KDE it was: System Settings > Input Devices > Keyboard > Advanced > Ctrl key position

3

I realize that this already has an accepted answer, but here is the One True Way to change Caps Lock to ctrl. This works on all versions of Linux, all distros, for the entire system (console, X, whatever). It sets the mapping in the kernel where it should be.

(echo $(dumpkeys |grep -i keymaps); echo keycode 58 = Control) | loadkeys -

Add this to a start up script (e.g., /etc/rc.local, or create your own).

On Debian (and derivatives) dumpkeys/loadkeys is part of the kbd package, if for some reason it's not already installed.

  • Unf I wasn't able to get this working w/ Linux Mint 18.1. Tried both manually as root and also adding it to /etc/rc.local, and tried logout and restart – Roy Truelove May 23 '17 at 16:12
  • Doesn't work on my Debian Jessie. – Ján Lalinský Jul 4 '17 at 12:37
1

On Mint 17.2, select Preferences -> Keyboard -> Layouts -> Options, select Caps Lock key behavior, select "Make Caps Lock an additional control."

0

Updating this thread for Linux Mint 18.3 (Beta) as this option seems to be a moving target.

  1. Click on Control Center from the Start Menu and select the Keyboard button.
  2. In the popup window, select the Layouts tab.
  3. In the Layouts window. click on the Options button towards the bottom.
  4. In the Options list, expand the one that says "Ctrl key position".
  5. Towards the bottom select the checkbox next to "Swap Ctrl and Caps Lock".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.