2

I frequently use emacs ess functions. Specifically, I use r-mode and run R in emacs. However, quite suddenly, emacs is no longer offering ess options. r-mode is no longer an option in emacs nor is R.

I tried purging ess and emacs (aptitude --purge remove emacs ess) and even removed my .emacs file and .emacs.d folder - to no avail.

I'm using Debian (Jessie). emacs23 was installed. In trying to get this to work, I installed emacs24, and then even xemacs (on the off chance). Still no success. I was having a problem with el-get -- so I purged and reinstalled related packages. Oddly enough, reinstalling dictionaries-common was some help there (see https://askubuntu.com/questions/295234/broken-emacs-installation)- but still no luck with emacs and ess.

There are no error messages installing, uninstalling, or reinstalling emacs, ess, or r.

How can I amend this?

  • What command do you run to get into the mode an are there any error messages? What OS is this? You said aptitude so I'm assuming some flavor of Debian, right? Which version of emacs? – terdon Feb 6 '14 at 14:00
  • I've addressed my problem in part by manually installing the ESS package from here ess.r-project.org/Manual/ess.html#Installation for now. – Donnied Feb 6 '14 at 15:52
  • 1
    Cool, could you post your solution as an answer and accept it please? – terdon Feb 6 '14 at 15:54
0

I've addressed my problem in part by manually installing the ESS package from the project's installation page for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.