1

Problem: User on Win7 machine. Copy a simple text file from Win7 local drive, through samba, to Linux ext4 dir. The content of copied file on ext4 dir is empty when user open it. Only 1 user has such problem. Other user copying file to same ext4 dir has no issue.

Tried so far:

1. Remove smb user, then readd user.
2. Copy to different ext4 dir, same problem.
3. Restart smb service, same problem.
4. Copy file from another Win7 and WinXP machine, same problem.
5. Tried copy file using WinSCP, to ext4 dir, the file doesn't get copied over and I got "Failure: Error code 4".  Ext4 dir is not full.

On Win7 machine, looking at file attribute: Other users' files have an attribute of 'A', but for this one particular user, her files have 'AP' attribute. The files with 'A' attribute open just fine. The files with 'AP' attribute can be opened, but there's no content.

I'm not sure how to fix this and where else to check. Can anyone here help?

Installed:

samba-3.0.33-0.34.el4
samba-common-3.0.33-0.34.el4
samba-client-3.0.33-0.34.el4
  • Have a look at the ACLs on the Samba server: getfacl /path/to/dir – Hauke Laging Feb 6 '14 at 6:01
4

The issue is resolved. As it turns out, the problem is due to user hitting the hard quota limit. Increasing the quota limit solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.