0

My machine crashed (would not start) and so I pulled my harddrives and memory (which was not stock) and brought to another identical Dell optiplex 755 which I found in the office. Now everything seems to work fine except for sporadic network behavior when connecting through ssh either to or from the new machine. After around a minute or so I get a broken pipe. If I run with strace all I get is "reset by peer".

Now, although I am completely new to debugging tcp issues, with the help of this post my thinking is that it could have something to do with dropped tcp packets. When I run

> netstat -s -p

I find that the "segments retransmitted" counter increased with 4 at the point where I got the broken pipe.

Before finding the above post I did the below tests suspecting it had something to do with the changed hardware itself: 1. ethtool eth0 (shows nothing weird, have full duplex) 2. ethtool -t eth0 (PASS) 3. dig (says NOERROR)

Any suggestions on what the problem could be and how/if I might be able to fix it?

  • I recall seeing some networking oddness when we started to clone linux systems in our clusters, because udev still had entries for the original system's MAC addresses. Look at /etc/udev/rules.d/70-persistent-net.rules and remove any rules from the old computer, and reboot. – Mark Plotnick Feb 5 '14 at 19:42
  • @MarkPlotnick Thanks for the suggestion. Unfortunately only the new MAC adress was found in /etc/udev/rules.d/70-persistent-net.rules. – fnokke Feb 6 '14 at 7:13
0

The issue was solved by switching to yet a third Dell optiplex 755 motherboard that had a defect graphics card. So, this time I brought HDD, memory and graphics card. I noticed however that I got my original ip-address back. So the problem is most likely to have been caused by changed ip (last set of numbers went from 69 -> 70 and then back to 69) or by some issue with the network hardware on the second board.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.