1

On Centos 5, for installing some program, i need to upgrade libxml2. But i can't because of another package (libxml2-python) that seems needing my current obsolete version of libxml2

[root] # yum install libxml2 Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile Excluding Packages from CentOS-5 - Plus Finished Excluding Packages from CentOS-5 - Updates Finished Setting up Install Process Resolving Dependencies
--> Running transaction check
---> Package libxml2.i386 0:2.6.26-2.1.21.el5_9.3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================================================================================  Package                           Arch                           Version                                            Repository          Size
========================================================================================================================================================== Installing:  libxml2                           i386                   
2.6.26-2.1.21.el5_9.3                              base                           799 k

Transaction Summary
========================================================================================================================================================== Install       1 Package(s) Upgrade       0 Package(s)

Total size: 799 k Is this ok [y/N]: y Downloading Packages: Running rpm_check_debug ERROR with rpm_check_debug vs depsolve: libxml2 is needed by (installed) libxml2-python-2.6.32-1.i686 Complete! (1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
1
  • What is that program you need to install?
    – schaiba
    Feb 4, 2014 at 9:42

1 Answer 1

2

So here's probably what your problem is. The version of libxml2-python that is installed is "2.6.32" And it looks like the YUM repository you are pointing to only has the dependant package, libxml2, up to version 2.6.26. Now it doesn't appear that CentOS 5 (or RHEL 5) has either of these packages at version 2.6.32. Therefore, apparently, your currently installed version of libxml2-python (version 2.6.32) came from somewhere else (maybe a newer CentOS or Fedora release?). My guess is that your currently installed version of libxml2 is also at 2.6.32 (which would match the libxml2-python version).

To fix this, first figure out where your libxml2-python package came from -- do an "rpm -qi libxml2-python" to get some more information on its source. What I would to, assuming you don't have another package that depends on that specific version, is to temporary delete it: "rpm -e libxml2-python", then re-install both libxml2 and libxml2-python with yum. Or, grab the version of libxml2-python from your YUM repo that matches the libxml2 package you are trying to install, and use "rpm --force" to force a downgrade of it.

In short, make sure in the future not to install packages from other repositories (or outside of YUM) that replace other core OS packages with their own versions (if that is what actually happened) -- this used to happen to me quite a bit when I was adding additional repos that weren't 100% compatible with the OS version installed (such as adding a newer Fedora repository to an older RHEL / CentOS build).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .