1
$ ps aux | grep xfwm
xralf  4365  1.2  0.4  19888  9444 ?        S    10:45   0:00 xfwm4 --replace --display :0.0 --sm-client-id 204399537-7a38-4196-8c31-43cf2f3542ac
xralf  4369  0.0  0.0   3324   788 pts/0    S+   10:45   0:00 grep --color=auto xfwm

after $ kill -9 4365

$ ps aux | grep xfwm
xralf  4379  0.4  0.4  20632  9976 ?        S    10:47   0:00 xfwm4 --replace --display :0.0 --sm-client-id 204399537-7a38-4196-8c31-43cf2f3542ac
xralf  4381  0.0  0.0   3324   788 pts/0    S+   10:47   0:00 grep --color=auto xfwm

Is it possible to kill xfwm4?

  • Why do you want to? In fact, the session manager is pre-configured to restart that one automatically. – Keith Apr 13 '11 at 9:20
  • I'm changing the window manager. – xralf Apr 13 '11 at 9:24
3

First, go to the XFCE4 Settings panel, then select Session and Startup, then select the Session tab. Then find the xfwm4 entry and change its Restart Style to Never. Then you can kill it.

|improve this answer|||||
  • Side note, I was looking for a way to turn off the auto restart functionality, but for the purpose of being able to copy over a new binary (for development purposes) before the restart occurs. This can be done with the disable session manager option --sm-client-disable. For example, after I build, I can run this to get the new client: pkill xfwm4; sleep 1 && sudo cp ~/xfwm4/bin/xfwm4 /usr/bin/ && xfwm4 xfwm4 --sm-client-disable & – Scott Sep 4 '17 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.