1

I am booting kali Linux from the USB. But it boots me into Kali login prompt. When I provide the credentials for root. It gives me root prompt.root@kali. Any pointers please on how to boot into GUI mode using live USB. enter image description here

enter image description here

closed as off-topic by Michael Homer, slm May 26 '15 at 22:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Michael Homer, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

3

Now that you have added snapshots to your question: The data on this USB device is corrupt. The reason you can not start X is because the libraries and/or binaries needed to start gdm3 can not be read by the Linux kernel.

To resolve this, reinstall Kali Linux again, ideally on a different USB device.

  • +1 and thanks a lot :) I initially tried formatting the USB but that did not work. I bought the new USB per your suggestion and it did the trick. – Forever Learner Feb 4 '14 at 16:26
1

Logon and try startx. Or service gdm3 start

Then you just have to open the file /etc/inittab as root, and add the following line at the end of the file:

x:5:respawn:/usr/sbin/gdm -nodaemon

If gdm3 is not a part of Kali, try installing it with:

apt-get -f install gdm
  • hi, thanks for your inputs. I tried above approaches but still facing the issues as shown in snapshots attached. – Forever Learner Feb 3 '14 at 16:28
  • Now things look different. And yes, in your specific case, follow samiam advice. – Quora Feans Feb 3 '14 at 23:45
0

Text mode to Graphical Mode:

I have recently faced a problem with my kali linux, The problem is that i can't get into graphical mode, When ever i reboot my kali its starts in terminal mode(tty3) and asked root password when i typed password it still shows me text. i tried many things to get into graphical mode.

Typing Startx to enter into graphical mode but it is used in backtrack not in kali. Later i tried pressing control+alt+f7 but still it didn't worked.

After searching all websites and blogs i noticed many things Like some told to type "use fsck command then reboot, first login by entering your password"

I tried fsck and came back with an error e2fsck cannot continue, aborting

And even tried gdm3 but it didn't worked

At some point i decided to reinstall the KALI. But i feared to lost the files in which i saved.

but don't worry about it in your case I will give you real solution for that

Before typing apt-get update and apt-get upgrade to install missing files

Let's check the Network connectivity by following steps, type the following command as it is..

service networking start
service network-manager start
service samba start
dhclient eth0

(ifconfig to check the net interface configuration is ok and eth0 is working right)

Then type apt-get update && apt-get upgrade


Next install chkconfig if its not installed through apt-get install chkconfig

Then check the status of level 2 of gdm3 using chkconfig --level 2 gdm3

Install gdm3 service if it's not installed using apt-get install gdm3

When I typed gdm3 it showed me "bash: gdm3:command not found", then I typed sudo apt-get install gdm3

after installing I just typed gdm3 in the terminal. Then it directly taken me to the graphical mode.

0

As seen in your screenshot above, your issue was that you typed apt-get -f install gdm - and you should have typed gdm3.

  • you didn't see that the culprit was a defect USB-drive? – guntbert May 26 '15 at 19:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.