4

I'm running the MATE edition of Linux Mint on my laptop. I have an external USB disk with a LUKS container on it. The USB disk is connected to the laptop's docking station.

Whenever I connect the laptop to the docking station, MATE pops up a window which says, "Enter a password to unlock the volume" along with a text field and options to forget the password immediately, remember until logout, or remember forever. (Not "don't show me this popup again," which is what I would prefer.)

Under normal use, I want to have this external USB disk unmounted and idle. I have a cron job which unlocks the disk via a key file, mounts the partition, and runs an automated backup. I don't want this partition to be mounted all the time, nor do I want it to be accessible to my ordinary (non-privileged) user account.

Is there any way to tell gvfs (or whatever is doing this) to please stop showing me the "enter password" dialog every time I dock my laptop to the docking station?

2 Answers 2

0

I am not familiar with the application prompting you for a password (gpg has a similar program called gpg-agent), but I would think that "remember forever" would make the password prompt not pop up again (since the password will be remembered).

To see what process is making the pop-up appear, the next time it appears, type in ps auxw in a terminal window and see if any of the processes appear to be a name for a password pop-up application.

Or, you may find someone here who knows the application if you post a screenshot of the password prompt in your question.

0
0

I had the same problem --> and it was thunar-volman with options for mounting USB.

Inside Xfce4 : settings > Removable Devices and Media > and uncheck:
"Mount removable drives when hot-plugged"
"Mount removable media when inserted"
"Browse removable media when inserted"

... after this Thunar will stop try to mount encrypted volumes

1
  • This works, but will, I believe, disable auto mounting for all volumes. This may not be what the OP wants? Jan 8, 2022 at 8:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .