I've followed this article, and been able to get a fully working 32-bit installation on a Kingston DataTraveler 8GB pen drive, with a BIOS boot partition, and a home/root ext4 file system without journaling partition, and no swap. I'm using GPT partitions.

The problem is that pen in which I installed Arch only works on my computer. That is, if I insert it in other computer (the ones I tested had Windows with BIOS, not UEFI), I cannot change the boot order, because the pen does not appear as a bootable device.

How can I get it to run on any computer, the same way the usual Arch Linux installation pen does? That is the whole point, to have a pen that is ensured to boot on any computer to which I have physical access, rendering its usual data protection measures, i.e. login passwords, useless! (evil laugh)

I see the normal installation pen has an EFI instead of a BIOS Boot partition. I don't mind reinstalling the system, but I'd surely prefer if I could copy the latest installation media ISO and tweak the necessary options (auto login, hostname, clearing of changes on reboot, etc.). Can I do that? How exactly? Is this supported?

What exactly, besides what is referred in the article, and the EFI boot partition, do I need to watch out for? Must I use fdisk or is gdisk OK? What bootloader should I choose? I'd prefer GRUB, simply because I'm used to it, but I heard Syslinux is better (and easier) for this purpose.

  • 1
    What does your grub.cfg look like? That determines the root filesystem after booting the kernel.
    – samiam
    Feb 3, 2014 at 0:31
  • @samiam, now it works, but as far as I recall, and can see in the old file I kept, the error was caused by some wrong settings (wrong UUID of the root FS, as you said, and a few more), even though I used grub-mkconfig. As I'm not sure I corrected those errors in /etc/grub before generating the config, I can't report an error. I'll remove that part, as now I think it was probably a mistake of my own.
    – JMCF125
    Feb 3, 2014 at 11:55
  • please tell us what happens when you try to boot on another computer. also, please tell us what computer model(s) you've tried the pen drive on, and whether they were BIOS or UEFI. if UEFI, let us know if you had Secure Boot off or on, and if you had Legacy Boot turned off or on.
    – strugee
    Feb 25, 2014 at 2:10
  • @strugee, I have discovered the solution. But the pen was not detected before. About UEFI, I don't know, but I've made a partition for it just-in-case. I am composing an answer (regarding BIOS), and will update the question ASAP.
    – JMCF125
    Feb 25, 2014 at 13:22
  • @strugee, updated the question. Is it fine for reopening now? I don't know what else to add.
    – JMCF125
    Feb 25, 2014 at 14:12

1 Answer 1


[...] if I could copy the latest installation media ISO [...]

As a more thorough inspection of the pen shows, all the default bootable pen has are images like ISOs. And so it does not really matter the system in which they're in is iso9660 itself; unless you were to extract every one of them, re-configured it all, and change from iso9660 to a writeable file-system. That is a lot more work than to re-install Arch Linux.

Also, GPT should be OK, but remember:

 *  If  Windows  is  to  boot  from  a GPT disk, a partition of type
    Microsoft Reserved (gdisk internal code 0x0C01) is  recommended.
    This  partition  should  be about 128 MiB in size. It ordinarily
    follows the EFI System Partition and  immediately  precedes  the
    Windows  data  partitions. (Note that GNU Parted creates all FAT
    partitions as this type,  which  actually  makes  the  partition
    unusable  for normal file storage in both Windows and Mac OS X.)

Considering this, the following is the partition table I used:

Device           Start          End   Size Type
/dev/sdb1           34      1048609   512M EFI System
/dev/sdb2      1048610      1310753   128M Microsoft reserved
/dev/sdb3      1310754      1312767  1007K BIOS boot partition
/dev/sdb4      1312768     15646686   6,9G Linux filesystem

Although I formatted /dev/sdb1 as FAT32, as supposed, this pen probably won't run on systems with UEFI, because GRUB was installed as for BIOS systems. I'm not sure whether one can make it bootable on both, but will keep searching.

But indeed the key to have is a Microsoft reserved partition, with no file system. Through hexedit (or even cat), one can see POSIX (guessing, the first word is Posix...) definitions in XHTML, it's almost all plain readable text. I found it quite interesting and unexpected, you may want to check it out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .